Quantcast
Jump to content

NBlackburn

Lots of parts for sale

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By M C
      Hey guys just bought a 07 trooper. Previous owner stated it ran great etc prior to clutch job then had issues. I drained tank, replaced plugs etc. found one of the injectors connectors was not connected and plugged it in. Solid 50psi fuel pressure.  It starts easier than previously on 3 cylinders but still runs very very poorly. I’m thinking the sound I’m hearing is it detonating at around 3k. It kinda sputters and falls apart. Sounds like clicking or something when it happens. I am at a bit of a loss, compression is a solid 150psi across the board with no movement. Verified spark and now am assuming all injector are functioning more or less correct as if I unplug any one it sound terrible at idle. 
       
      A note, I tapped plugs at .7 manual called for .9-1.1 but that seems super over doing it but I will try adjusting them to 1.0
      additionally I’ve noticed the fan in rear doesn’t turn on. 
       
      anyone with any help I will be in your debt.
    • By Jim Sabin
      I have a 2012 MSU 500 that recently was having an issue with the motor not starting,  I ended up reworking the ground wire at the fuel pump leads and now I have notice that when I switch to 4Wheel drive, it does not work. Any ideals what going on?
    • By Heath Herring
      I have a 2014 4010 trans 4x4 (KAF620REF). Are the rear left and right driveshaft assemblies the same part number? I ordered the two sections individually for the rear right & they are coming up too short in length. Possibly the wrong parts ordered by the dealer? Thanks in advance.
    • By Anthony Butler
      Soo for my second problem lol, 2009 trooper 1100 5 speed , will not engage 5th gear , all others work fine but seems like 5th doesn't engage completely and wont grab the gear. Any idea on where to start looking for issues, or what to look for in regards to linkage. 


×
×
  • Create New...