Quantcast
Jump to content

2012 Kubota 400/idles good backfires when given gas


SPF4524

Recommended Posts

Troubleshooting Kubota 400.  it  is tough to start, I have to pump the gas pedal. After it starts it will idle, but bogs down and backfires when I  give it gas. I've replaced the fuel pump and it did not fix the problem. Any other suggestions that would not require replacing throttle body and ECU ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Hi sun 500
      hello everyone, i just joined this forum to try my luck, few days ago i bought an old (dont know exactly), 2011/14 hi sun 500cc ""carburated"",  was not running at the time, but i fell was a good deal and decided it to bring it home to play with it, this is the issue, i bought and installed a new carb, and pump, i repositioned the battery location and upgraded to a "car batt", reconnected the fuel lines and started it, but it only runs with the choke ON, i checked the bowl, it does have fuel,but for some reason wont inject it to run, i came across a video that say that ""the body small tank had to be connected for the cart to run" (was deleted when bought), sure enough i got it to run sporadically , but the so called ""small body tank'' often runs out of fuel and wont refill itself , i had to couple times do it manually, so how does that small tank works ?..what does it do?..and why if  bypass it , the cart wont start?....any help?..thanks so much!!!
    • By FloridaMan
      I have a 2012 Massimo MSU 500 that died. I found that it didn't have spark and the fuel pump wouldn't run. Checked all fuses and none were blown.
      Went through and replaced the ignition coil, HT lead and spark plug. Still no spark.
      Thought it could be the fuse/relay box because I didnt' know much about the machine at that point so I replaced it. No spark.
      Then I replaced the ECM just because I was running out of ideas. No spark.
      I removed the 9 pin connector and hardwired it making sure that they were no wires got swapped. Still no spark.
      Then I replaced the wiring hardness. In doing so, I replaced the 9 pin connector with new ones. I made sure all wires were matched up between the engine harness side and the other harness assembly. Still no spark.
      I have no other ideas what to do. My fuel pump doesn't kick on and I have no spark. I have 12V on the fuel pump, ignition coil and fuel injector, but no ground from the ECM control.  I unplugged the fuel injector and waited for a diagnostic code but nothing ever came in. It makes me think that the ECM isn't powering up. I've checked for 12V on pins 18 (purple wire) and 15 (white and black wire). I also checked for ground on pin 2 (black wire). All are good.
      I am out of options here and I have no idea what else it could be. I have all connections redone and are coated with dielectric grease. I've checked all easy things like fuses and making sure I have 12V in the right placed. I would appreciate any help.
    • By nods
      Less than 40 miles can barely start. Dealer is working with Hisun on a number of other issues on this UTV. Can not get clear info on the meaning of these E codes this is getting. Anybody have some clear info for me?
    • By Dave N.
      2020 Massimo Buck 400 - Won't start. Can hear the starter spinning, but motor never turns. Relay? Starter? Worked fine one day and not the next. Thanks for any help you can provide.
    • By catalyst
      We own a 2020 Kubota RTV-XG-850, with only 400 hours on it and it has been at the dealer 3+ months. We were just informed our engine failed and requires a complete rebuild at only 400 hours! There is a loss of compression in cylinder #1, which is causing backfiring and a loss of power. There is also excess gas in the engine oil. 
      We are just outside of the manufacture's warranty period, and they are serving us a nearly $5000 repair bill, with only a 90 day warranty.

      A member at a different forum had the same issue at 22 hours and fortunately, his RTV is under warranty. He was informed that "short tripping" (as Kubota describes it) causes gasoline to enter into the engine oil, which causes a dilution of engine oil and eventually leads to catastrophic engine failure. This killed our engine in under 400 hours!

      Is anyone else with a 2018-2022 XG-850 running into similar issues?
       
       
×
×
  • Create New...