Quantcast
Jump to content

Tgilly22

Rear End screeching/squeaking

Recommended Posts

Is anyone else experiencing a screech or squeak in the rear end while moving?  I'm not referring to the suspension but the wheel movement.  My challenger 2018 750 has had this problem since I bought it.  I took it in for service and they said they deglazed the rotors and cleaned some parts.  No noise for 10 miles or so and now it is back.  I have a hard time believing it is brake related because the noise doesn't change when the brakes aren't applied.  I have less than 120 miles on it and now I have noticed a tear in the drivers side seat on the side toward the door and it doesn't appear to be done by a sharp object like a knife or tool but rather a jagged vertical and lateral tear.  Anyone else out there experiencing these?  Other than these issues I love the machine.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Airsense00
      Hi y'all, 
      I am looking to buy a 2018 Textron EV or a new 2020 Tracker EV. Tracker is the new name of Textron. I'm having trouble finding a snow plow mount and kit. I want to pull the trigger and buy one but I have to have a snow plow to make it worthwhile. Any of you have the EV with a snowplow or know which mount works? Front or center mount? Thanks!
    • By BAER
      Have a lot of problems shifting gears on a hill, anyone have this problem 
    • By Verno
      I installed the 2019 exhaust upgrade yesterday.  Overall went very well, but my rear driveshaft / u_joints are extremely hot.   Is there some sort of heat shield that should be added.  TIA for any input
    • By Verno
      Just returned from Colorado with my 2017 cub 750.  I was very concerned since my last 3 sxs were Polaris.    Overall things went well.  Excluding any altitude over 11500 ft.  Removed the screen at 10000 ft and the tube to the intake at 11250.   From there on up could not get over 4k or 18mph.   Rode and handled great.   Other than cracking the cheap excuse of an exhaust  system the machine did excellently. Did 100 miles the first day out.
       
    • By Travis
      The cables are sort of seized up on the emergency brake, they still work but i have to wiggle and pull on em to get them to release, i pulled the drum off but cant see a way to remove the cable. It is kind of dirty inside the drum where it was leaking so i need to run to the parts store and buy some parts cleaner so i can see everything better.
       The shop manual i have  does not cover parking brake cable removal, well.... it does kind of. it says "Remove parking brake cable at both ends" 🙄
       We'll see
       EDIT: ARRR! Looks like my rear axle seal is leaking, there is a small puddle on a machined step below the seal and it smells like Trans oil. felt around the wheel cylinder and it isn't coming from their.....  I guess my weekend is planned for me LOL


×
×
  • Create New...