Quantcast
Jump to content


08 SEMA Coverage


Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Ron from the Mitten
      I purchased a 2008 Qlink Rodeo 700 a few years ago.  I am from Michigan.  Anyone know of any local repair shops?  I had a dead battery, so I replaced that, started right up, ran the quad down the road, (this was last year), put it in the barn, shut it off.  then a couple weeks later, went to go start it again, and nothing.  I have power to the dash lights, horn, turn signals, wench etc, but nothing to the starter switch, and I hate electrical crap.  Battery still reads 12.x volts.
       
      Any suggestions would be amazing.  I've owned it over 2 years, and haven't run 1 tank of gas through it.  No time to screw with it, and very frustrated.  Hoping someone can offer some advice of value.
    • By alevins
      Good day all, 
      searching here but cannot find the answer,  Hisun been working fine and now reverse limiter seems to be engaging and cannot back up, cannot find a clear solution to disable the limiter. found a possible relay?  not sure which one or to cuut a wire at ecu but a picture or diagram would be helpful
      thank you for any help in advance
    • By MJG
      Hello, 
      I found an 08 Renegade for sale and looking to purchase it.  I haven’t heard too much about these machines and any insight would be much appreciated.  Are they good machines?
    • By Amagi
      Hi to all. I’m new on this forum and I need some help. I have a 2008 arctic cat 700 xtx prowler. I have no spark. 
      I have done the following repairs. 
      changed piston and cylinder 
      change CDI 
      change ignition coil and spark plug
      changed speed sensor
      changed stator and flywheel 
      Changed voltage regulator 
      after all this I still have no spark. 
      i have verified all fuses and they are all good. 
      please help. I would like to get it running. 
       
    • By William Carberry
      I have a MSU 500. I will start and run but requires basically full throttle to move. Does this machine have a drive belt? If so how difficult to change?
×
×
  • Create New...