Quantcast
Jump to content

David Hopkins

2013 Bennche Bighorn 500 no 4 wd

Recommended Posts

I have a 2013 Bennche Bighorn 500 that will not go into 4wd, I have replaced the switch already so looking to replace front servo. Does anyone know where I can get a u tube of how to remove and install the servo???

thanks in advance 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Paul Mckay
      Checked cable and shifter linkage. All looks good. No slack or slop. When put in reverse you can hear something internal on the gear case grind the kick out reverse. Has anyone else had this issue and no what parts usually cause this?
    • By Robbie Wyre
      I'm working on a 2005 Cub Cadet side by side and I'm trying to remove the front two axles.  I have a slide hammer puller on the inner joint and with all my strength they will not budge.   Anyone have the same issues and is there something I'm missing or a trick of some sort to pull these out?   Any suggestions please and thank you.
    • By Relick
      Hi all. New to the forum. I have  a 2013 700 Powermax (Hisun) I bought new and beat the hell out of hunting , fishing and running old bush roads in Northern Ontario. It’s been a great machine. I’ve done a few clutch mods but pretty much stock. Went to 16gr greaseless weights (ceramic). I am now looking at 700 Rhino clutch cam plate to make it easier on sliders. Does anyone know if the plate will fit. Are splines and ramps the same. Any help would be greatly appreciated 
      Thanks Relick
    • By Joe Toup
      There is a lot of great info also being passed around on this FB page of anyone is interested.  This is where I found the post for the real-time software and reader. 
       
      https://www.facebook.com/groups/187829158450490/?ref=share
       
    • By Chad Rice
      HELP - my wife and i just bought a 2013 joyner trooper 1100 and we rode for 2 evenings with no problems. Went to ride last night and all of a sudden it acted like something was catching up and it didn't want to move easily. Whatever it was must've broke and now it moves with no problem but is making a rubbing/grinding noise somewhere in the backend. Could it be wheel bearing, differential, or something in cv shaft. Any info or similar experiences is appreciated. 


×
×
  • Create New...