Quantcast
Jump to content

Loaded 2008 Trooper T4 for Sale


nogd

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By BuggyBoy
      Hi, 
      I'm in Australia and need to replace the footbrake pads and cable (weak point if you ask me, bad design), plus might as well get the main brakes done at the same time.
      Anyone know an Aus dealer, or, know the parts number or equivalent in the petrol version?
      Cheers.
    • By Xov
      Just received delivery of a 2024 AMP Pro.  Thought I'd start a thread with my impressions as I use it and learn more.  There doesn't seem to be a whole lot of real-world usage information out there on this model.  Hope this will help others as they research.
      Intended Use Cases
      Fire mitigation / slash removal from a 5 acre forested and well-gamble-oaked property.  The previous owners thought as much about fire mitigation as I do about fashion: not much. Snow removal Stump pulling General hauling (rock, lumber, etc.) Weimaraner energy depletion.  Wasn't an original use case, but a nice added bonus.  Experiences So Far
      Wasn't impressed that two of the bumpers on the underside of the bed where it sits upon the frame were missing.  The metal on metal contact has damaged the powder coating and the frame.  I expect a little better QC.
      I've only put a few hours on it, so not a ton to report on usage.  It isn't quiet; it's silent.  I can't even detect an electric note from the motor. I removed (and subsequently replaced) the motor cover noticed that the motor is German and made by Schambuller.  The motor controller is Italian and made by Dana TM4.  Given the operating specs of both I found on the web, I suspect both are higher quality than the previous Navitas (which is supposed to be decent).  The motor is rated at 25 hp and 71.5 lb-ft of torque.  It feels very powerful.  All the torque is delivered instantly, if desired.
      The bed is huge and has an electric dump as standard.  Great feature but would like it to go up a bit more.  Probably not feasible from an engineering perspective, but I want and I need ;).
      Power steering is nice, but vague.  Probably common to many UTVs, but I am accustomed to more direct results from input.  Plan early and plan often.
      In our first full day of usage, we hauled about 1/2 as much slash as the entire rest of the year when I was doing it by hand cart.  I may get fatter, but I'll also get more done.  After a few days of usage, the battery meter has gone down by 1/10th. 
      Until next time...


    • By Steve B
      My "R" light on the dash will not go out when I take the UTV out of reverse and put it into any other gear. Is this just the light switch issue or will this effect engine performance in the other gears?
    • By Hugh
      My 2018 Hisun sector crew engine cut off after about 15 minutes run. There is no indicator of what is wrong, no error code just die and won't restart until it cool down. I notice that the fan is not running but the temp indicator is on low temp, no overheat indicator. I checked the radiator fluid, it is cool to touch.
      Cooling fans are working, I can hear it running once awhile if I can get the engine warm up enough.  Thank you for all the help.
       
      Hugh
    • By Ron from the Mitten
      I purchased a 2008 Qlink Rodeo 700 a few years ago.  I am from Michigan.  Anyone know of any local repair shops?  I had a dead battery, so I replaced that, started right up, ran the quad down the road, (this was last year), put it in the barn, shut it off.  then a couple weeks later, went to go start it again, and nothing.  I have power to the dash lights, horn, turn signals, wench etc, but nothing to the starter switch, and I hate electrical crap.  Battery still reads 12.x volts.
       
      Any suggestions would be amazing.  I've owned it over 2 years, and haven't run 1 tank of gas through it.  No time to screw with it, and very frustrated.  Hoping someone can offer some advice of value.
×
×
  • Create New...