Quantcast
Jump to content

Emmersode

Riding friends

Recommended Posts

Hi everyone, My wife and I are now the proud owners of a 2015 RZR 4 900. Looking for riding club/friends to join/or ride with and make friends. Love riding trails and sand. 

 

image.jpeg

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By miten000
      Hey guys...I have a 2015 ODES Dominator X4 800cc...I had recently tore the belt up and was able to get a new one on and had no problems.  The other day I got stuck and smoked the clutch out a bit trying to get out and since that time I have had a constant "clicking" noise coming from the primary clutch.  Then noise is present at idle and low speeds but goes away under load.  I took the clutch apart and assume that this noise is coming from either the clutch sliders/weights or shoes.  I plan on replacing these soon.  
      However, today I put the clutch back together to get the bus out there and ride around the neighborhood and I have a "jolty" start and while cruising in "H" the secondary clutch suddenly opens wide and I lose power.  When revved the secondary clutch will not grab and continues to open.  I can place the UTV back into "N' and then back to "H"...the secondary clutch stops spinning and the belt grabs as normal and I can continue on.  Anyone have any idea what is going on or have experienced similar problems?
      https://drive.google.com/file/d/1bR6kVo2QsB6e6G6NK3jWjAoQpJCmeyVf/view?usp=sharing
      ODES clutch problems.mov
    • By johnpeter
      2015 Polaris RZR XP 1000 eps On Ebay
      https://www.ebay.com/itm/2015-Polaris-RZR-XP-1000-eps/284035887180?

    • By Barry E Spires
      I have an issue with my odes. It will start up and run but when you give it gas it stumbles and cuts off. I have replaced the fuel pump,fuel filter, fuel injectors, mass air flow sensor,idle air control,throttle position sensor,air filter,spark plugs,and throttle body also I have no vacuum leaks either. I have even replaced the ECU. Does anyone have any idea about what could be wrong? Engine only has 1045 miles on it
    • By miten000
      What aftermarket belt do you all use that fits...my dealer used the DAYCO XTX 2236...???
    • By Kirk Falk
      Hello,
      I have a 2018 Dominator LT 1000 and I am wanting to stiffen up the ride.  What is the best way to accomplish this, tighten the recoil spring up or add air to the shock.  I can't find any information on the procedure.  Also, since im asking questions........my top end rpms doesnt seem to be where it should be.  Max RPM is 6100 and usually drops down to 5800 maxed out.  Im just wondering if everyone else has the same experience.
      Thanks,
      Kirk Falk


×
×
  • Create New...