Quantcast
Jump to content

Sign in to follow this  
venery99

Radiator Temp Sensor

Recommended Posts

Does any one know of an aftermarket temperature sensor for the radiator in the Joyner Trooper? I think my sensor has failed open because the radiator fan is always on high from when I first start it up. I replace the relay thinking that is was stuck open, but that didn't help.

Share this post


Link to post
Share on other sites


Does any one know of an aftermarket temperature sensor for the radiator in the Joyner Trooper? I think my sensor has failed open because the radiator fan is always on high from when I first start it up. I replace the relay thinking that is was stuck open, but that didn't help.

Not sure, well pretty sure, the fan runs full speed all the time. It runs during the start up and once the engine is running, it runs. Only has one speed. go to parts and piece and find the schematic and download it.

Kinarfi

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By 2wpuller
      Has anyone replaced the stock shocks and springs on their 2015 Dominator 800 X2 to ride alittle smoother are just changing the springs out.I gotten alittle spoiled riding in my son's rzr 1000xp.
      My wife just made a comment why don't ride as smooth as our son's thing.lol
      I'm 62 she's 61 the little rough ride doesn't really bother me. I drive a concrete mixer for a living. 
      I really like the Odes it's pretty good power for for only 800cc
      I took off the cat and the stock muffler. Put a glasspack with 2" inlet and outlet it has a good deep tone and not really very loud. I'll find out Sunday when we hit the woods .It's definitely more peppy. 
    • By PierceIt
      Hi everyone - I was driving my 2017 Cub Cadet Challenger 750 EPS today on the ranch when it dies on me. It started right up - and then as i was driving after about 50 feet the engine just turned off. It was running perfect before it cut out on me. No alarms, no weird sounds or smells. It just turned off. 
      When I turn the ignition key, the starter cranks away and the battery and starter turns fast and strong - but the engine doesn't start.
      I've confirmed gas flow to the carb - that the fuel filters are clean and clear. I've replaced the spark plug with a brand new one. I checked every fuse with a meter. I have confirmed air filters and airflow are good. 
      But the darn thing cranks away without the engine even making a sputter or even attempting to fire.
      Is there a kill switch somewhere that could have been tripped? I checked the seatbelt sensor, the brake sensor, and parking gear sensor - all are working and i'm in Park, pressing down on the brake, and have the seatbelt latched when i try to start. but - nada!
      It acts like it isn't getting a spark. but like i said i put in a new spark plug. I have a feeling there is a sensor or an electrical kill switch somewhere that tripped. 
      open to any ideas.
      thanks all
      Pierce
    • By nocturnalsixer
      Hello everyone,
      I have decided with my Joyner keep overheating only at high speed miles of driving over fifty mph would cause trooper to overheat so the radiator doesn't flow enough and keep getting clogged up with gravel dust
      Otherwise at all low speed it work great
      i want to know.
      Did anyone put in a different radiator?
      I'm thinking about a much bigger radiator and e fans set up
    • By Karla Phelps
      A arm bushings needed for a 650 Joyner 2005
    • By William Lyons
      I have changed the plug, changed the fuel injector, drained the fuel tank looking for water, replaced the coil , checked out the wiring on top of the fuel tank looking for bad connection .  The UTV will sputter but will not start.  Any ideas will be helpful!
       


×
×
  • Create New...