Quantcast
Jump to content

RZR, Ranger, Rhino, Teryx, and Prowler Cages!


Recommended Posts

Well guess its time to introduce myself, My name is stephen and i work out here and Sandworks Sand Cars in Ogden UT. We got our start ten years ago and have been building some slick high speed desert cars and have made a few magazine covers. Anyways we have moved into the UTV market I Just thought i would post up some of our rear cage kits we build and get some opinions and answer any questions you guys might have!

post-1531-0-65230700-1331155143_thumb.jpg

post-1531-0-10408300-1331155146_thumb.jpg

post-1531-0-88319300-1331155237_thumb.jpg

post-1531-0-02676200-1331155253_thumb.jpg

post-1531-0-22802500-1331155257_thumb.jpg

post-1531-0-85600600-1331155259_thumb.jpg

post-1531-0-55492900-1331155320_thumb.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By AndySwish33
      Brand new t boss 550. couple of questions. 
       
      1.  Do you need speakers in order to play music ?  Hooked my phone to Bluetooth no sound 
      2.  On screen registration.. it won’t let me fill in the info on the touch screen.  Navigation works but the registration portion does not 
      3.  Is there a data plan you can get or need ?  
       
      thanks everyone 
    • By AlphaSerenity
      Hello,
      Before I invest $10k+ into a brand new UTV for the farm, I want to get my feet wet with a fixer upper and learn the mechanical side of things. I acquired a 2022 Hisun Axis 500 (Lowes-specific model) from an auction for $500. It has only 200 hours and 120 miles on the engine. It looks like the previous owner used it for ranch work and didn't drive it on trails, deep water/mud, or anything too crazy.
      While it runs and moves, it has some problems. It struggles to accelerate up any incline in high and low range and sometimes stalls when I let off of the throttle or change gears. When I apply throttle in neutral, it sounds like it is struggling for fuel/air and pops. When I decelerate, there is a grinding sound coming from the clutch, which I've read to be related to the one way bearing and is semi-common. The last thing I've observed is sometimes the speedometer display sometimes will show a much higher value for a few seconds after barely touching the throttle. Based on the documentation, if a problem is detected from the sensors, the instrument panel display should have an error code rendered on the screen in place of the time, but this isn't happening. Here is a video showing some of these issues (engine is exposed with console removed):
      https://www.youtube.com/watch?v=FFAkO5TaGps
       
      Here is another video of the clutches in action:
       
      I've done some research, but information on this specific unit and sister units is limited. There does seem to be transmission and clutch issues reported. I still need to check into the head gaskets. I don't have the equipment to test compression right now, but I do plan on ordering what is needed soon. I do have an order in place for some cables to read the diagnostics from the computer. There is a shop two hours away from me that works on Hisun products, but I am hoping the problem can be identified and is something within my ability to handle. Below is what I've already investigated.  I am leaning towards the primary clutch needing replacement right now.
      After getting it home and unloaded, I did the following maintenance/checks to it prior to operating it further:
      Changed the engine/clutch oil (and filter) and gear oils using manufacture recommended viscosity Changed the air filter and checked for cracks in the air intake flow. Verified good suction. Cleaned the throttle body Changed the spark plug and verified the gap was within spec (0.6-0.7mm) Changed the coil and coil wire Changed the fuel lines, fuel injector, and verified the fuel pump was outputting the correct initial prime pressure for ignition and continuous pressure after ignition. Also completely emptied the fuel tank and made sure octane 91+ fuel is being used per manufacturer specs. Ran seafoam through system too. Cleaned the spark arrester and verified no cracks or gaps in the exhaust flow Changed out the O2 sensor Checked all wired connections to ensure they were secured and no breaks were visible Checked the belt for tightness and for any signs of wear and tear Verified 4WD and the differential lock function as expected - still hesitates and struggles uphill Verified the fan gears in the shifter are not corroded and working as expected ECU was reset after replacing sensors and fuel-related parts  
       
      Thanks!
    • By MOTORHEAD1959
      ATV just clicks when trying to start. Battery is good, has a new starter, and all the wiring looks good. any suggestions on where to go from here? thanks 
    • By malenurse13
      We just bought a used 2017 American Landmaster TW450. No hour meter that I can find, so not sure exactly how much it has been used. 
      The first 2 days we had it, the starter was a little sketchy, but it started after 2-3 tries. Sometimes when turning the key, we would hear a loud metal "clink" sound. Like the starter made contact, but didn't have enough power to turn. 
      THIS MORNING... Turning the key, we hear a single click sound. That's it. Even with a new battery, the starter is still doing the same thing. Both batteries (old and new) were reading 12.8 volts on volt meter. So I'm wondering what else could be going on? Any ideas on what to look for would be greatly appreciated...
      Thank you!
    • By DJ Brusenski
      checked all the fuses and relays, I can jump start it with the key in the on position. it will not key start need some help, thanks
×
×
  • Create New...