Quantcast
Jump to content

UTV as a compact truck


Recommended Posts

Finding small trucks are no longer available for purchase in the USA (Ford Courier etc) I had been looking to import a small truck from another country, but there seems to be problems registering one of these (smog). The problem I have to overcome is a sharp turn in my drive in front of my garage. I could not do the turn in a Ford Ranger. Someone suggested a UTV. They are street legal in my state, so that works fine.

I would be driving around town, occasionally hauling appliances, and moving snow. Off-road capabilities and some rugged trips to the mountains would be a big plus.

Having very little experience with UTVs or ATVs, and never owning one myself I looked through all the specs and can find no problem. My question is what limitations would I likely run into using a UTV as a small truck? The two likely candidates (based on top speed and hauling capacity) are the Arctic Cat Prowler 700 HDX and the Polaris Ranger XP 900 LE.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By skittle021
      So I've got a Hisun 550 that I was doing some work on that required removing the CVT and it's housing. Upon attempting to reinstall the clutch, sheaves, etc, I found that the belt no longer fits - it's far too wide. None of the parts have been replaced, they're all OEM. Exactly the same parts as what I took off a few weeks ago.
      To be more specific, my belt is 1.25in wide, but the gap between the clutch and the primary sheave is only 7/8in wide. I'll include a few photos to explain.
      Has anyone ever experienced such a bizarre problem? Any help at all would be appreciated, I've been stuck on this for a month. I'm open to just about any suggestion.
      Photos: 
       





    • By nods
      Less than 40 miles can barely start. Dealer is working with Hisun on a number of other issues on this UTV. Can not get clear info on the meaning of these E codes this is getting. Anybody have some clear info for me?
    • By MJG
      Hello, 
      I found an 08 Renegade for sale and looking to purchase it.  I haven’t heard too much about these machines and any insight would be much appreciated.  Are they good machines?
    • By AlphaSerenity
      Hello,
      Before I invest $10k+ into a brand new UTV for the farm, I want to get my feet wet with a fixer upper and learn the mechanical side of things. I acquired a 2022 Hisun Axis 500 (Lowes-specific model) from an auction for $500. It has only 200 hours and 120 miles on the engine. It looks like the previous owner used it for ranch work and didn't drive it on trails, deep water/mud, or anything too crazy.
      While it runs and moves, it has some problems. It struggles to accelerate up any incline in high and low range and sometimes stalls when I let off of the throttle or change gears. When I apply throttle in neutral, it sounds like it is struggling for fuel/air and pops. When I decelerate, there is a grinding sound coming from the clutch, which I've read to be related to the one way bearing and is semi-common. The last thing I've observed is sometimes the speedometer display sometimes will show a much higher value for a few seconds after barely touching the throttle. Based on the documentation, if a problem is detected from the sensors, the instrument panel display should have an error code rendered on the screen in place of the time, but this isn't happening. Here is a video showing some of these issues (engine is exposed with console removed):
      https://www.youtube.com/watch?v=FFAkO5TaGps
       
      Here is another video of the clutches in action:
       
      I've done some research, but information on this specific unit and sister units is limited. There does seem to be transmission and clutch issues reported. I still need to check into the head gaskets. I don't have the equipment to test compression right now, but I do plan on ordering what is needed soon. I do have an order in place for some cables to read the diagnostics from the computer. There is a shop two hours away from me that works on Hisun products, but I am hoping the problem can be identified and is something within my ability to handle. Below is what I've already investigated.  I am leaning towards the primary clutch needing replacement right now.
      After getting it home and unloaded, I did the following maintenance/checks to it prior to operating it further:
      Changed the engine/clutch oil (and filter) and gear oils using manufacture recommended viscosity Changed the air filter and checked for cracks in the air intake flow. Verified good suction. Cleaned the throttle body Changed the spark plug and verified the gap was within spec (0.6-0.7mm) Changed the coil and coil wire Changed the fuel lines, fuel injector, and verified the fuel pump was outputting the correct initial prime pressure for ignition and continuous pressure after ignition. Also completely emptied the fuel tank and made sure octane 91+ fuel is being used per manufacturer specs. Ran seafoam through system too. Cleaned the spark arrester and verified no cracks or gaps in the exhaust flow Changed out the O2 sensor Checked all wired connections to ensure they were secured and no breaks were visible Checked the belt for tightness and for any signs of wear and tear Verified 4WD and the differential lock function as expected - still hesitates and struggles uphill Verified the fan gears in the shifter are not corroded and working as expected ECU was reset after replacing sensors and fuel-related parts  
       
      Thanks!
    • By JFC
      I have a  3500LB Winch that only runs in one direction.  Inward but not Out.  Replaced the solenoid module.  Makes "click" when I push the "Out" button and the motor tries to spool out but then stops and begins to "click".   Does anyone have suggestions what I should try next?       
×
×
  • Create New...