Quantcast
Jump to content

plumber

Steering Box

Recommended Posts



also curious as to what happened...steering rack updates with a new upper plate or changing out to the most current steering box is what I have seen....we have been putting power steering into the newer/updated boxes without trouble...that box does look kinda cool tho....Hardy

Share this post


Link to post
Share on other sites

What happened to the old one?

Hit a tree with the front tire blow off the top of the steering box. Dedub has done a subaru steering in he's it drives real nice but it rides even better he added a shock and left the stock one's in. Rides a lot better than mine.

Share this post


Link to post
Share on other sites

what parts are damaged is the plate still straight did it just strip out the screws if it just stripped out the screws you can fix that with a helicoil kit I think a helicoil repair is stronger than the original

Share this post


Link to post
Share on other sites


Re-drill ant tap a size larger. On the steering box above, 1.5:1 sounds awful fast for the trooper. If I'm right, that would be only about 135 degrees of steering wheel turn from stop to stop. Stock is about 2 turns and its still hard to turn. I had 3 turns from stop to stop on mine and it helped a lot. I don't think the power steering would be enough to push the 1.5:1 box.

Share this post


Link to post
Share on other sites

Re-drill ant tap a size larger. On the steering box above, 1.5:1 sounds awful fast for the trooper. If I'm right, that would be only about 135 degrees of steering wheel turn from stop to stop. Stock is about 2 turns and its still hard to turn. I had 3 turns from stop to stop on mine and it helped a lot. I don't think the power steering would be enough to push the 1.5:1 box.

Thanks Yes I can re tap But I was just looking to see whats out there. Lenny those cams are on the money with the new intake and fuel controller it runs real good the wife said my be to good since I hit the tree. I would like to see some else do the intake I thought it was better than the fuel controller. All 1100cc Chery motors have them on them except the trooper and that were I think is were you lose power at. On my air/fuel gauge it went from 11 when I start it to a 11.6 is what it will read when I start it now.. the part # is 472-1008013

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By chris.minix
      Is the any other ball joint brands out there for the Troopers? 
    • By farmcrew
      I recently got a 2007 Commando 650 C4 and I'm in the process of going through it from stem to stern. The AZ sun has really taken it's toll on all the plastic and rubber. One CV boot is torn and the others are probably not far behind. Most of the rubber on the control cable ends are on bad shape and the steering rack boots are almost completely disintegrated. Anyone have a source for the steering rack boots?
    • By Dan B
      Does anyone know if Joyner USA in Phoenix AZ is still in business.  Can't get onto their website.  The FB postings are over 1 year old.  Doesn't seem like the owner is interested in keeping customers interested or updated in what's going on.  Hasn't been at the Riverview address in a couple of years.  Last I knew, he was on S 18 St.  There's a website that says Joyner USA is at the 3700 block of E Roeser.  Don't know at the moment if it is the same business.  I bought a couple of wheels from him last year and I want to buy two more.
    • By MMaster
      Have a new r4 approx 800 miles just noticed the tach wont sweep with ignition on but the speedo does, also will start with out the clutch engaged.  my 2012 r4 tach and speedo both sweep and it wont start unless the clutch is engaged , any ideas why?. Any help would be greatly appreciated.  Thanks Matt


×
×
  • Create New...