Quantcast
Jump to content

4srmaintenance

New member from the PNW w/2007 Mule 3010

Recommended Posts

Hi, my name is Ethan and I’m new to the UTVBoard community. I'm looking to use this forum to ask mechanical questions and browse information that may help me troubleshoot problems that arise with my 2007 Kawasaki Mule 3010 Trans4x4 Diesel. Of course if I have any confident answers to other member questions I could offer potentially helpful information as well but at this point I’m not very familiar with these vehicles so my mechanical knowledge of them is extremely limited. I’m a lead general maintenance tech at a private community in Port Angeles, WA and part of my job is to service all the equipment we have to best of my ability within the limitations of the facility and tools we have. Our 2007 Kawasaki Mule is the one piece of equipment that gets the most use and we absolutely depend on it to enable maximum efficiency when performing the various duties of my job.

I look forward to being part of this forum connecting with people who I can learn from! Happy holidays BTW!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • 2009 Joyner trooper starting problems

      I have a no cranking issue with my joyner. It has a chery 1100. It will click but nothing after that.  New battery. I tried banging in the starter while holding key in start(old car trick). Now the  starter solenoid won't even clunk. Just hear s click fron the relay now.  My assumption is the starter needs replacing.  Any ideas of other things to check? Does anyone have diese block diagrams?  Got no clue what fuse or relay goes to what

      By Whisper Snowbird, in Joyner UTV SxS Forum

      • 12 replies
      • 109 views
    • Every Kawasaki part imaginable!!

      Hi, all, I am here to say i have found an excellent source for kawasaki parts, It's run by  Eddie Babbit. It is called Kawasaki Partshouse. run by Babbits online, Muskegon Michigan. http://www.kawasakipartshouse.com/oemparts Just the other day i ordered piston rings, for my Mule 550, They got here and a Oil ring, and smaller ring were missing from the box, Kawasaki took responsibility for the "Accident" and  I had also contacted babbits, and they replied and they said" keep the old rings, order a new set and you just pay shipping" so i got $30 piston rings for 8.95!!!? Free shipping on orders over $50!!!  

      By Travis, in Kawasaki UTV SxS Forum

      • 2 replies
      • 1,551 views
    • Wiring problems with 2014 Coleman Outfitters Utv(Hisun) 400 4x4

      Hello all, I have what I hope is a quick question. I am working on this 2014 Hisun SxS and the wiring is a mess. I am currently just trying to find the electrical wiring Color Code for this machine. I have Maintenance Handbook for a wiring diagram for what it calls a 'HS400UTV-Emark'. That's the only thing my son got with this machine when he bought it and I can no list of the color codes anywhere in this book. We're not against buying manuals but have learned to be picky as there are many that supply little real detailed information. This is a machine that I am trying to get the 2004 Kodiak motor they installed wired up to run and install a complete new wiring harness for the Utv at the same time. Any help that someone might have to offer would be greatly appreciated. Thank you all and I hope you all had an enjoyable Thanksgiving holiday.

      By res2fr, in Hisun UTV SxS Forum

      • 3 replies
      • 110 views
    • A Stubborn Mule: Mule 2500, electrical and other questions

      HI! Thanks for the forum. I am currently installing a turn signal and horn kit on a Mule 2500 that was gifted to the local ranch owner. His health is not so great, and other than a car, he has no other way to get into town. The driveway is a mile long...  Attached are some photos. The prior owner disconnected the parking brake light grounding/indicator cable. I fixed it and reconnected it (shown in photo). Following the wiring harness, there is a 6-pin block (see second photo) up front, nothing plugged into it. I have what I think, is a fairly accurate wiring diagram. Problems: I cannot find the VIN anywhere on the vehicle. I have no paperwork on it and neither does the owner. We know who owned it previously but he doesn't have paperwork on it either. I have looked NUMEROUS places, and googled it. I do not know the year. There does not seem to be any indicator light for the parking brake. I think the light was physically removed from the dash (see third photo). What parts are missing? What are they named/part numbers if you have them? What I have done so far: Fixed the parking brake switch Fixed the brake lights, the wiring in the back was pulled out, cut, a mess. (fixed) Added a third center high brake light, tying it to the wiring harness. Positioned just below the air intake. (added) Added bright red LED strip lights, at the inner side of the rear downtubes, to be used later for the turn signal indicators. Ready to order a $15 steering column strap-on switch for hazards and turn signals. Image descriptions: Parking brake switch (fixed) What are these? They were bundled up underneath the dash with a ziptie. The beige block has the red wire return from the parking brake. Wiring diagram. These seem close to the existing vehicle. Dash photo. So you can see what is missing and let me know.

      By John Mason, in Kawasaki UTV SxS Forum

      • 13 replies
      • 838 views
    • 2010 Strike CDI questions

      Good morning,   I am new to the Hisun world.  I am trying to track down the part pictured in this post.  Can anyone help me out?   I just picked up a 2010 Strike 800  that I intend to set up with hand controls so that my disabled son can use it on dirtroads, etc. Mike

      By iflybyu, in Hisun UTV SxS Forum

      • 0 replies
      • 84 views
×