Quantcast
Jump to content

Piggyback ecu on trooper?


Volkz VLOGS
 Share

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By Fib103182
      I have owned my 2015 Hisun HS700 Crew  for about 3 or 4 months now. I got it used and was supposed to run good but was not put all the back together from a stator upgrade due to previous owner said he was going to out a stereo system on it. Anyway I have worked it much more than I have rode it. I seem to work on it 2 days and ride it for a hour. Me, my wife, and 2 kids (10 and 18) enjoy it but the engine compartment gets so hot. I've replaced the water pump and burped the cooling system and any other thing I could think of to bleed the air out and think its good with no air and water circulating. Fan seems to run fine and be on about all the time. Changed the coolant twice and oil 3 times. I noticed the engine really has nowhere for heat to go because heat rises and no air flow at all. Has anyone had any experience in this area? Any DIY tricks or any advice in removing the heat out of the engine compartment and getting it to a tolerable temperature. Im about to sell it if I can't figure something out and go waste money on a big name brand but I won't have red legs and arm from engine heat burning me and my wife. They machine never acts like its to hot or anything but it feels like it is. Thanks in advance for any and all help. 
    • By Travis
      Kawasaki Mule 1000 / 2010 / 2020 / 2030 / 2500 / 2510 / 2520 /3000 / 3010 / 3020 / 500 / 520 / 550 / 600 / 610
      A lot of the older mules use a float and sight glass for viewing fuel level in the tank, mine, like many others has been fogged over for several years making it hard to see the needle. I've used all sorts of cleaners in an attempt to clear it up, but none ever worked long term.
       I finally discovered this kit from ATV Works for $17.00, just the sight glass and new attachment pin (which you can not get from kawasaki)  Kawasaki want's you to order the entire float and gauge assembly for nearly $40. I ordered it last night and it hopefully should be here by the end of the week. When i get it in, i will make a video on how to install it.

       
       
    • By TTWacker
      Any help appreciated….
      I have a 2015 Massimo Gunner 250s that I had to do the top end on. I can’t find a correct video or manual that matches the timing marks this one has for the chain and cam gear. Does anyone have the correct marks to line up???
    • By Zero
      So i have a 2011 EFI 700. the SxS will crank right up everytime without any issues. If i let it run or ride it for about 10 mins it will shut off and then it may turn on if i am lucky but most time i have to let it sit for like 3 hours and then it will run again. i have done the following
      -New fuel filter
      -New injector
      -New spark plug
      -New coil pack and plug wire
      -New air filter
       
      Also could i get a grizzly 660 engine and put in it or would it not work.
    • eManualOnline
    • By Robby
      Hello, I have a 2013 500 utv hisun. Was running ok and cut out while parked. Bike will not start now. It turns over, but won't fire. I have no spark and no fuel. I replaced fuel pump, ignition coil, spark plug, cdi, voltage rectifier and all the fuses and relays. Could bad stater cause no fuel because I can't hear the fuel pump priming. Any info on where to start looking for problem.
  • Similar Tagged Content

    • By Kflan99
      Hi ya all,
      My Joyner Diff is busted. Any leads on a mechanic who can rebuild it ...or replace it?  I can seem to find anyone. Thanks!!!!!
      JNSZ650UV

    • By Viper0012
      Hope I have this in the right area but i am having an issue with the drive by wire system on my Joyner sandviper  with the 2.0. I have done all electrical checks to pedal and the electronic throttle body. But have no actuation of the throttle, meaning the engine starts and idles but no vroom vroom. Wondering if anyone has come across this issue I am leaning towards ecm but due to the rareity of parts hoping not.
    • By DONALD1968
      Why can’t I get my 1100 Joyner trooper to do anymore than 30 mph?
    • By Tom F
      Looking to find a new tie rod for the trooper or a recommended substitution I have ripped the heim joint out from end of the tie rod & the threads are gone. Any suggestions?
    • By Bryan83c
      Need input on compatible clutch sets I can upgrade joyner 1100cc 2018 sand viper with.    Something autozone might carry  and what cars are these chery motors most compatibility with

×
×
  • Create New...