Quantcast
Jump to content

High Mountain ATV Jamboree 2009 (In Idaho)


Paiute3
 Share

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By RickinMT
      2009 Hisun 700. Well, back to square one. I've been doing this rebuild since Jan. 2021. MANY new parts and fixes and re-starts and working/then broke/then working/then broke... and on and on. Last week I had a good ride, about 18 miles. Ran great. Parked in the garage for 2 days and then the exact same problem as last time-- Cranks and cranks, about 6 or 8 times, and then click: nothing. I get one click and a red warning light on the dash but it's too small and doesn't say what it is. It's not the battery: it's fully charged. Had it on a charger overnight afterward and still getting one click. It's like the starter is stuck or the engine is seized. The last time it happened I took it to a guy who's rebuilt many of these and he found the starter was full of oil! Black oil. He said it was black 'cause it got cooked trying to crank. Put in a new starter and he did all kinds of adjustments and between him and the neighbor it was running great. Now it's stuck again. I'll pull the starter when I calm down.... One of the MANY new parts we threw at it was a new battery. it's got plenty of power, 350 cold cranking amps. Is it possible to have TOO heavy a battery? But has ANYONE run into this?      
    • By Steve Sheets
      Prowler won't start when temperature is freezing or below. 45 degrees  and up it starts every time. Turns over but won't fire when cold. Any ideas  on what's wrong?
    • By John Pongrass
      Recently got a Titan Sniper E4 utv, doesn’t work of course, it charges and powers up controller, but if I turn it on when any switches are on it gives me two blinks on the controller, which from what I’ve found on the controller info I’ve been able to find, means it’s an order error, I don’t have all the switches in the neutral area on power up. But when everything is neutral it just comes on solid which says is normal operation, but doesn’t do anything. It is an EV,  battery voltage holds steady at 48v, all accessories work, but no movement. Replaced the 5 k pot in the throttle, no difference. I can’t find any info at all on these, company went out of business long ago (wonder why?)  it has a sevcon gen4 controller in it. I can’t find any info on the utv, year, etc. no idea what order to put switches in on startup( which is the only error I get.) does ANYBODY have an owners manual, info, anything to do with these?!?! I know it’s a Chinese unit but that’s it. Thanks in advance for any help.
    • By pchow
      This just started happening a few rides ago. 4x4 and full lock were working fine. Now it won't go into 4x4 or lock. Took the servo motor off and it turns and operates just fine when I press the 4x4 button and lock button so I know its not that. Been doing some research and people seem to be saying that the slider (picture with red arrow pointing to it) should be all the way to the right for 2 wheel drive, middle for 4x4 and all the way left for locked. I tried pushing it to the left and it won't move any farther than what you can see in the picture. Seems like it's hitting something. It'll move all the way to the right, but I can only move it about 1/4" to the left (where it is in the pic now). Been trying to find an exploded view of the front diff with no luck. The Yamaha parts diagrams don't even show this slider as a part (diagram I have attached).

      Couple of questions. Anyone have an exploded diagram of what the front diff parts should look like for a 2009 Rhino 700 FI
      Special Edition? Some people say there should be a "fork" that the slider moves but I can't see that on the parts diagram either. Is my pic with the blue line pointing to the fork? Anyone with any ideas? Would like to get my 4x4 working again so I can do some snow wheeling soon.
       



    • eManualOnline
    • By Alex
      View File 2009 Husqvarna HUV 4214, HUV 4414, HUV 4414-XP Owner's Manual
      2009 Husqvarna HUV 4214, HUV 4414, HUV 4414-XP Owner's Manual
      Submitter Alex Submitted 01/12/2022 Category Other UTVs  
  • Gallery Images


×
×
  • Create New...