Quantcast
Jump to content

2012 Polaris rzr4 900xp EPS rzr crew


Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By TomW
      I had a problem 6-8 mo ago when the unit would not start . But you could see power on the dash. The starter solenoid was replaced and it has been fine until yesterday. When I started it up I noticed a high pitched noise coming from under the front. Like a alarmbuzz ..It seemed to drive fine so I went ahead and used it off and on for a hour or so . The noise would not go away . I parked it in the shed and lifted the hood . It seemed to be coming from the battery compartment ( where the new starter solenoid is) I jiggled the connections and the noise changed timbre and then the machine went dead. No power at all . No lights . When you cross the two poles on the starter solenoid ( previously last year it would start and run ) nothing. Checked the battery and it is fully charged . I checked the fuses inside the battery box and they all looked good  but I must be missing something. Anyone have a clue what I need to do next to R&R. The closest repair place is 2 hours away in Mississippi . Any help would be appreciated.
    • By ETHIEL
      Spark plug keeps fouling. after 10-15 minutes of running any ideas what to look fore 
    • By Hugh
      My 2018 Hisun sector crew engine cut off after about 15 minutes run. There is no indicator of what is wrong, no error code just die and won't restart until it cool down. I notice that the fan is not running but the temp indicator is on low temp, no overheat indicator. I checked the radiator fluid, it is cool to touch.
      Cooling fans are working, I can hear it running once awhile if I can get the engine warm up enough.  Thank you for all the help.
       
      Hugh
    • By Gary Odom
      I bought a tracker 88sx crew in 2023. It has a whishing noise coming from the front end. Starts out low and gets louder as speed increases. Took it back to the dealer and they said it was normal on this model. Any suggestions as to what may be causing this.
    • By johnpeter
      2011 Polaris RZR 900 Xp On Ebay
      https://www.ebay.com/itm/266702209616?

×
×
  • Create New...