Quantcast
Jump to content

Hisun 550


Kevin Slack
 Share

Recommended Posts

After talking it apart and looking at the diagram the factory had a compression spring inside my rear drive shaft connecting seat, which is number 10 on diagram. Should of been just a flat washer with a lock washer then nut.  Mine was nut flat washer and compression spring. The only compression spring used is supposed to be up front number 45.  But part 10 and 6 is on its way. Picture of diagram and parts destroyed.

15753221304064705608231313953066.jpg

IMG_20191126_141622658.jpg

IMG_20191126_141705035.jpg

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By Hisunsadman
      I have recently acquired a 2012 CFMOTO 500 CC side by side. The previous owner said that it ran great but had a gas leak by the throttle body that caught fire and ruined most of the parts on top. It also melted the cover and fan for the stator. Does anyone know of a good place to get all of these parts? I usually use Amazon for all my 2020 hisun parts, but can't really find the ones I need for this. If anyone has any ideas I would greatly appreciate it. Thanks in advance
    • By Chuck Winburn
      I bought an axis 500 brand new, hauled it home and the light indicator for 4 wheel drive is not working.  Is there a something the store didnt tell me, or is it messed up right off the assembly line? Any thoughts or advice is greatly appreciated. Thank you!
    • By MJG
      Hello, 
      I found an 08 Renegade for sale and looking to purchase it.  I haven’t heard too much about these machines and any insight would be much appreciated.  Are they good machines?
    • By Zero
      So i have a 2011 EFI 700. the SxS will crank right up everytime without any issues. If i let it run or ride it for about 10 mins it will shut off and then it may turn on if i am lucky but most time i have to let it sit for like 3 hours and then it will run again. i have done the following
      -New fuel filter
      -New injector
      -New spark plug
      -New coil pack and plug wire
      -New air filter
       
      Also could i get a grizzly 660 engine and put in it or would it not work.
    • eManualOnline
    • By JacobG
      I bought a used 2015 Coleman HS400UTV-2. I assume this has a wet clutch and plan to use Mobile 1 T4 oil. Any feedback would be appreciated. 

×
×
  • Create New...