Quantcast
Jump to content

Choke cable adjustments


johnney

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By donwan
      View File 2017 Hisun Strike 900 Service Manual
      Here's the service manual for the 2017 hisun strike 900.
      Submitter donwan Submitted 05/29/2024 Category Hisun  
    • By Buddee
      Put a new carb on the 500 to replace the leaking OE one.  Machine idles fine and mid and top end runs great.  It tends to have a hesitation right from the start - bottom end.   Thinking it may be the air/fuel screw??  I didn't do anything with the carb out of the box and is it direct replacement for my machine.  Of interest is the manual choke doesn't seem to work very good now.... wonder is it getting too much air?
       
      Any help appreciated!
       
       
    • By todd93
      Hi, all! I. I'm new to the board, hoping someone could help me out! I have a 2020 Hisun Sector 550C that I bought new in 2021. Today, I took some stuff next door to my parents. When I went to leave, I turned on the key, heard the solenoid click, but no lights, no guage activity, no fuel pump, and no starter. 
       
      The battery is good, I checked all the fuses, they are good. Not sure if the relays are good, or even what to look for there. Is it possible that it's maybe a wire? 
      I'm really stumped on this one! Any help would be deeply appreciated! Attached is a pic of the fuse box layout. 
       
      Thanks! 
      Todd 
    • By JimS409
      I picked up this Hisun 700cc for a good deal. no crank no start unit 1900 miles on it. Put a new battery and starter solenoid fired right up but sounded rough some kind of rattle/clunk noise.  Does anyone know what this noise could be? Couldn't get a better video of it running as i don't want to risk doing more damage. Drained the oil it looks good no metal in it. 

      445374820_7315077208620291_6073155782020130975_n.mp4  
    • By DLJ
      Have a Hisun 800 it runs for about 35 minutes then stalls. Crank's over but has no spark. Let it sit for 15 to 20 minutes and it starts and runs again for about 35 minutes. Changed the CDI / ECU controller and still does it.
×
×
  • Create New...