Quantcast
Jump to content

Choke cable adjustments


johnney
 Share

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By Ric Silveira
      I like to get ngk idirinium plug for it anyone know part number.
      Thank you
    • By Fib103182
      I have owned my 2015 Hisun HS700 Crew  for about 3 or 4 months now. I got it used and was supposed to run good but was not put all the back together from a stator upgrade due to previous owner said he was going to out a stereo system on it. Anyway I have worked it much more than I have rode it. I seem to work on it 2 days and ride it for a hour. Me, my wife, and 2 kids (10 and 18) enjoy it but the engine compartment gets so hot. I've replaced the water pump and burped the cooling system and any other thing I could think of to bleed the air out and think its good with no air and water circulating. Fan seems to run fine and be on about all the time. Changed the coolant twice and oil 3 times. I noticed the engine really has nowhere for heat to go because heat rises and no air flow at all. Has anyone had any experience in this area? Any DIY tricks or any advice in removing the heat out of the engine compartment and getting it to a tolerable temperature. Im about to sell it if I can't figure something out and go waste money on a big name brand but I won't have red legs and arm from engine heat burning me and my wife. They machine never acts like its to hot or anything but it feels like it is. Thanks in advance for any and all help. 
    • By Quade
      This is my first UTV and it ran great the first 500 miles. Then it slowly got harder and harder to start. Now I have to keep giving it gas when I first start it for about 1 minute until it will idle by itself. This past weekend I took it on the trail and it died 15 minutes into the ride and lost all spark. I got towed home and tried to see if I had spark the next morning which I did and it started but died 10 minutes later. Anyone have any ideas what I should do or check? Anything would help thank you!
    • By Josh Lounder
      I acquired an older HISUN BIG BUCK 500 that hasn't run in years.  Little elbow grease and she's running.  I have a few more parts to switch out but when revving the engine over 4K the r light starts blinking.  After googling and seeing other people I replaced the rev limit switch under the air box and found the same issue.  I traced the green and white stripe wire back to the computer module and found no breaks in the wire and cleaned the connectors.  Still same issue.  I then cut the wire right at the plug and grounded it directly to the battery.  I can now rev over 4k rpm however the light still blinks and when in reverse the light no longer lights up.  Anyone else run into this?  Can R light blinking mean something else.....HELP, what am i missing?????
    • eManualOnline
    • By Manfred
      I have a 2020 coleman ut 400. I can"t Find anyone that sells a snow plow system for this model. Need help.....

×
×
  • Create New...