Quantcast
Jump to content

Massimo knight 500 no start


Swimmer1
 Share

Recommended Posts

  • 1 year later...

My Massimo knight 500 I shorted Solonoid out on frame now I have no power to anything I changed fuse box still the same no dash lights when you turn key no fuel pump no anything works could I have shorted ecu box???

No power to dash or fuel pump key motor winch I shorted solenoid to frame then that happened I bought new fuse relay box anybody have idea like ecm

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By Travis
      Kawasaki Mule 1000 / 2010 / 2020 / 2030 / 2500 / 2510 / 2520 /3000 / 3010 / 3020 / 500 / 520 / 550 / 600 / 610
      A lot of the older mules use a float and sight glass for viewing fuel level in the tank, mine, like many others has been fogged over for several years making it hard to see the needle. I've used all sorts of cleaners in an attempt to clear it up, but none ever worked long term.
       I finally discovered this kit from ATV Works for $17.00, just the sight glass and new attachment pin (which you can not get from kawasaki)  Kawasaki want's you to order the entire float and gauge assembly for nearly $40. I ordered it last night and it hopefully should be here by the end of the week. When i get it in, i will make a video on how to install it.

       
       
    • By Robby
      Hello, I have a 2013 500 utv hisun. Was running ok and cut out while parked. Bike will not start now. It turns over, but won't fire. I have no spark and no fuel. I replaced fuel pump, ignition coil, spark plug, cdi, voltage rectifier and all the fuses and relays. Could bad stater cause no fuel because I can't hear the fuel pump priming. Any info on where to start looking for problem.
    • By IslandHopper
      Can anyone tell me if their MSU 500 or 700 fuel pump and injector cycle when you turn the key on? This will help me rule out the Crank Position Sensor as a problem.
      I just bought this non-running and the service manual is not much help.
      Thanks
    • By Jerod
      When I first bought the Massimo 550L, everything was great until we stopped in the woods and it just wouldn't start again.  When the key is first turned and the kill switch is on, you hear a magical sound that tells me the fuel injector is ready to go and may have put fuel in the start process.  The same sound happens with my ducati motorcycle.  When it wasn't working, the sound never happened.  They after fooling around with the electrical harnesses, etc, put a new fuel injector on, it worked.  Fastforward 9 months and the same thing is happening.  It started this morning Nd the magical sound was there before I started the engine.  Later in the day, no magical noise.  Can anyone provide advice?  Thanks
    • eManualOnline
    • By Steven78
      Hi I have a t boss 410 is about a year old with 150 MI and it feels like the brakes are stuck when you take off but in neutral it rolls perfectly I also have a t boss 550 that does not do this so was just wondering if anyone else has had this issue or if it is common with this machine also on the 410 have had the stator motor and voltage regulator replace once already and think it is bad again not sure if this would have anything to do with the other issue any help or advice would be greatly appreciated thanks in advance
  • Similar Tagged Content


×
×
  • Create New...