Quantcast
Jump to content


2014 Polaris Ranger Crew


Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Mnfish
      I have a 2016 Cub Cadet 750 Challenger Crew. My in tank fuel pump is inoperative. Can I put in an external inline electric fuel pump to replace the intank one? The inline ones are about $350. An inline electric one is about $25. Both are easy to replace just really expensive for the intank one. Any kind of inline external pump I should look at? What PSI is needed? Thanks for any help 
    • By donny
      Hello I am new here but have had this machine for about 5 years. I am having issues with it surging and sometimes sounding like a small backfire thru the intake.  When putting in low, high or reverse it will struggle then go full power then struggle. It will only do the small backfire thing while in neutral reving it many times. Once in awhile it will throw a check engine light.  
      Parts replaced/checked:
        I have checked the valve lashing, timing and adjusted. Parts replaced are the coils, spark plugs, injectors, fuel lines, fuel pump, IAC sensor, TPS sensor, throttle cable, speed sensor, primary and secondary clutch and belt.
    • By Kidrock
      I got a 2014 bennche bighorn 700 efi it gets fire it’s getting gas but just won’t start up and half way backfires through the air box what would cause that problem I need all help I can get please and thanks
    • By Hugh
      My 2018 Hisun sector crew engine cut off after about 15 minutes run. There is no indicator of what is wrong, no error code just die and won't restart until it cool down. I notice that the fan is not running but the temp indicator is on low temp, no overheat indicator. I checked the radiator fluid, it is cool to touch.
      Cooling fans are working, I can hear it running once awhile if I can get the engine warm up enough.  Thank you for all the help.
       
      Hugh
    • By Gary Odom
      I bought a tracker 88sx crew in 2023. It has a whishing noise coming from the front end. Starts out low and gets louder as speed increases. Took it back to the dealer and they said it was normal on this model. Any suggestions as to what may be causing this.
×
×
  • Create New...