Quantcast
Jump to content

Search the Community

Showing results for tags 'american sportworks'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Calendars

  • Community Calendar
  • Kawasaki Owners club's Cool Accessories

Forums

  • UTV BOARD Forums
    • UTV General Discussion
    • General Discussion - Anything
    • New Members Area
    • UTV Ride Reports - Where to Ride
    • UTV Events and Rallies
    • UTV News and Information
    • UTV Pictures and Videos
    • All Other Off-Road Toys
  • UTV Side x Side Specific Forums
    • Arctic Cat UTV SxS Forum
    • Can-Am BRP UTV SxS Forum
    • Cub Cadet UTV SxS Forum
    • Hisun UTV SxS Forum
    • Honda UTV SxS Forum
    • John Deere UTV SxS Forum
    • Joyner UTV SxS Forum
    • Kawasaki UTV SxS Forum
    • Kubota UTV RTV Forum
    • Kymco UTV SxS Forum
    • Massimo UTV SxS Forum
    • ODES UTV SxS Forum
    • Polaris UTV SxS Forum
    • Ruesch UTV SxS Forum
    • Renli UTV SxS Forum
    • Textron Off Road UTV SxS Forum
    • Yamaha UTV SxS Forum
    • Other UTV SxS Forum
  • UTVBOARD Classifieds & Product Info
    • UTV Off-Road Classifieds - Buy & Sell
    • UTV Product Specials and Promotions
    • New Product Showcase
  • Supporters, Website Links, Clubs, etc
    • UTV and ATV Clubs, Communites, etc.
  • UTV BOARD Support & Announcements
    • UTV BOARD Announcements
  • Kawasaki Owners club's Kawasaki Mule
  • Kawasaki Owners club's Kawasaki Pro FX models.
  • Kawasaki Owners club's Kawasaki ATV's
  • Kawasaki Owners club's Cool Accessories
  • Kawasaki Owners club's Photo Gallery

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location

miles from

UTV Brand


Interests


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype

Found 1 result

  1. American SportWorks LM 650 won’t start at times. Starter won’t engage the solenoid just “clicks” much like a weak battery would cause. Battery was replaced and problem went away and then came back. Replaced positive battery terminal. Problem resolved then returned. Replaced negative battery terminal. Problem gone then returned. Replaced the positive and negative battery cable ends. Problem resolved and now returned. The repair lasts for maybe 12 starts, then the solenoid just “clicks” again as it will with a weak battery. So I replaced the ignition switch. Problem solved for a week. With each “fix” the problem is resolved but only temporarily. Does anyone have any suggestions ? To replace the starter is expensive especially if it’s not the problem.


×
×
  • Create New...