Quantcast
Jump to content

Prepurchase help?


Recommended Posts

Hello all,

I am new here as I am trying to purchase a new to me machine to use on our farm and timber land.

I am torn between a 2019 Polaris 570 Full size (Windshield and cover)with 1000 miles and a very clean 2013 Polaris Ranger XP900 LE EPS with 2200 miles. Windshield, rear glass, cover, winch, new tires and front shocks.

The XP900 does cost more but is larger and better equipped. The 570 is priced extremely low which could allow for the accessories to be purchased to equal the 900, but it still would not be the XP900 LE EPS in aminities.

I am open and gratefull for any advice that can help me get this settled and move on to other things.

 

Thanks in advance,

Jeff

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Hugh
      My 2018 Hisun sector crew engine cut off after about 15 minutes run. There is no indicator of what is wrong, no error code just die and won't restart until it cool down. I notice that the fan is not running but the temp indicator is on low temp, no overheat indicator. I checked the radiator fluid, it is cool to touch.
      Cooling fans are working, I can hear it running once awhile if I can get the engine warm up enough.  Thank you for all the help.
       
      Hugh
    • By buckrub
      Hey guys! Newbie here. I'm an old man who's better with plowing a mule (4-legged kind) than these newfangled beasts. I, and a friend of mine, just bought new Coleman sxs and are having to finish the assembly. I've been reading on this site and I'm falling on the mercy of you experts. The only way I'm an expert is that an "ex" is a has been, and a spurt is a drip under pressure. LOL First off, the 2 buggies have no ignition switches. They seem to mount on the dash, not the opening in the steering wheel shaft cover, so we ordered new ones that are supposed to fit. They are 8 inches long, and have a 4-wired white plugin which is slightly rectangled when looking at the end of the plug. The trouble is there's nothing to plug into. There is a three-wire grey plug close enough to reach the four-wire plug, but of course, they are not compatible. 
      Secondly, the blinker, light, ect. unit on steering wheel just spins around when touched. I see no way in heaven or earth to secure it. I've looked at a diagram on the Powersports site, but can't detect how it mounted. Fellows I'd be so grateful for any help with this. Me and my mule will even plow your garden for free, for your help. LOL 
       
    • By packersfan
      I have a hisun 500 got from a auction and when turning a corner left or right it's a two hand job then when you left go snaps back.any help on what to look at would be appreciated.
      Also blows blue smoke until she gets warm then it's ok 
    • By MJG
      Hello, 
      I found an 08 Renegade for sale and looking to purchase it.  I haven’t heard too much about these machines and any insight would be much appreciated.  Are they good machines?
    • By lonerider98
      At the end of last year my Coleman UT 500 will not go into reverse. I can hold it over toward the reverse to move it nut it won't lock into reverse. Anyone have this problem? Winter is just about over and going to have to get this resolved. Thank You!
×
×
  • Create New...