Quantcast
Jump to content

Recommended Posts



looking for parts input shaft have 1100 sand viper do any other buggy trans fit

Look at Joyner Forum on line. I believe that someone there post pictures and info about one of the VW transmissions being a direct replacement.

Happy Trails

Share this post


Link to post
Share on other sites

Look at Joyner Forum on line. I believe that someone there post pictures and info about one of the VW transmissions being a direct replacement.

Happy Trails

Now that I think of it it could have been on line at Buggy News.com , try both.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By DirtGrl
      Hey guys! My throttle cable broke in its housing. Can anyone tell me what aftermarket cable would work for a 1100 renegade Joyner?
      TIA
    • By CharlieCampbell
      I recently purchased a used 2008 Ruesch XR.  The Pinyon is gone in the rear differential and the differential needs to be rebuilt or replaced. Does anyone know where you can find Ruesch parts?



    • By Anthony Butler
      So my rear diff lock cable is seized on a 2009 trooper 1100 T2 . How do i remove the end that goes into the diff ? 
    • By [email protected]
      I'm a new member, and want /need to pick someone's brain here.
      this mule was not running very well. Idling rough and appeared to be flooding.
      After reading as much as I could, I decided to buy and install a new throttle body. I installed the new throttle body today and it runs good up the road, but I can't get the thing to idle. 
      when first cranked, the engine goes to wide open even though the throttle is in the rest mode.
      It never did this with the old throttle body. 
      Is a new throttle body plug and play, or does it need to be programmed ?, Or, is there something wrong with this new throttle body ?
      Any in site to my problem  is greatly appreciated


×
×
  • Create New...