Quantcast
Jump to content

Sign in to follow this  
utvman

Desert Bloom Rally

Recommended Posts

Join us for the Desert Bloom Rally. We have three great rides planned along with a Dinner Cruise Saturday night.

When: March 1st and 2nd, Registration starts at 7:00 am

Where: Quartzsite Arizona

What: Family friendly fun. ATV’s, Motorcycles, [...]

View the full article

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Jhen
      I just purchased a Joyner Trooper T2.  Does anyone know if it can be registered to use on the roads in Arizona?  It has the street legal stuff like mirrors and turn signals.  It also has catalyst and air sensor.  I tried to get it insured and insurance told me "it's a dune buggy".   We don't insure dune buggies!   The title, which I can't get changed until the 28th of July (appointment issues) shows Joyne  ATV.  I really enjoy the Trooper and it fills the bill for what my wife and I were looking for.   
    • By JDH
      Hi guys,
      I have a Rural King version of the Hisun Sector 250 with about 75 miles and 15 hours on it.  It just started being difficult to start and idle.  But if I hold in on the gas a little it will start and run until I left off.  It also runs good and will run good until I stop then it idles for a few seconds then quits.  Its about 4 months out of warranty.  Battery voltage is fine before, during, and after starting.  Oil is clean and clear.  Gas is fresh.   I can hear the fuel pump spool up when I turn the key to actually start it, not when I turn it to the on position though like on most other UTV's I have owned.  Its really odd and has me perplexed.  The only other thing that I have noticed is that the engine temp indicator on the left side of the dash only indicates one bar regardless of how warm the engine is.  Other than that, it runs great.  Just hard to start and won't idle.  Any suggestions?  It has me  perplexed.
      Thanks
       
      Jason
    • By Keith
      Hooked up a new light bar for when I push snow. I think the video will speak for itself 
      IMG_1311.MOV
    • By Alex
      Get ready! We're bringing the world‑renowned Nitro Circus to the Glamis dunes for not one, but three exclusive boundary‑breaking shows!   This is a Camp RZR you don't want to miss.   By pre‑registering, you get reserved access to the show and are automatically entered to win one of the Grand Prize Giveaways!   Pre‑registering will get you on the list, but be advised that the first 100 people to check-in at Camp RZR Friday, October 25th will get closest to the action with premium viewing for the Saturday night show.   Learn More   Register Now     RZR Vehicles Shop Accessories Shop Apparel Explore All Off-Road Vehicles                            
    • By Baddeadpool
      How’s everyone,  anyone got rides planned, ? Looking for clubs or just good people to ride with



×
×
  • Create New...