Quantcast
Jump to content

rocmoc

Coral Pink Dunes, Kanab, UT - AGAIN!

Recommended Posts

This place is great and did not get enough the first time. We will arrive afternoon of Aug. 13th, play Aug. 14-16 (3 days) & head home Aug. 17th. Only hang-up is completing the Jeep. Anyone interested?

rocmoc n AZ/Mexico

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By GarySeven
      I bought a Titan Explorer back in 2012 and have had nothing but electrical problems with it ever since. It mostly sits in the garage and I thin I have 160 hours on it since I got it. The place I bought it from is gone and although I suspect it is a Chinese or Japanese I cannot find any service manuals on it.
      I'll post up some pics in the general forum in the hopes that someone can point me in the right direction. What I would like to do is to pull ALL of the wiring out and start over with bare bones... nothing but essential operations.
      This looks like a good group so hopefully I can help as well as be helped.
    • By Kelly Stump
      Has anyone rebuilt a head on a joyner trooper 1100? Where can i order those parts from?
    • By bjones
      2007 610 mule will foul a pug after 1 hr of run time on clock.  Plug will be black with sut.  Buddy go a 610 and it does same thing. Have had dealer adjust valves twice and still does it.  When i bought mule valves were ticking and I ran it that way for some time and took it in and dealer adjusted valves and that is when problem started.  I rechecked valves and the were tight and I adjusted to .005 and still fouls plug.  I always use no ethenal gas and have gone to a hotter plug.  I have read that this is a common problem with mule.  Any help appreciated.
    • By JDH
      Hi guys,
      I have a Rural King version of the Hisun Sector 250 with about 75 miles and 15 hours on it.  It just started being difficult to start and idle.  But if I hold in on the gas a little it will start and run until I left off.  It also runs good and will run good until I stop then it idles for a few seconds then quits.  Its about 4 months out of warranty.  Battery voltage is fine before, during, and after starting.  Oil is clean and clear.  Gas is fresh.   I can hear the fuel pump spool up when I turn the key to actually start it, not when I turn it to the on position though like on most other UTV's I have owned.  Its really odd and has me perplexed.  The only other thing that I have noticed is that the engine temp indicator on the left side of the dash only indicates one bar regardless of how warm the engine is.  Other than that, it runs great.  Just hard to start and won't idle.  Any suggestions?  It has me  perplexed.
      Thanks
       
      Jason
    • By OlEd
      Head gasket replacement, what’s a top quality head gasket to use? Should a person stud the head? Where would I find a place that sells both? Thank you for any info. 


×
×
  • Create New...