Quantcast
Jump to content


Fuel Regulator to Intake Manifold Connection


petethedog

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By LongSun
      I can not find it on the board, so I'm afraid I'm the only cheapo on the forum.
      What is the fuel economy of the Hisun HS590? (I guess it is the same as the HS550)
      I count in liter per 100 km, but if you use MPG it's okay with me, but please tell if you use the US or UK MPG!
    • By KVAN
      Have a new to me 2021 Coleman UT400. Runs great for 15 minutes then dies from a dead battery. It appears my unit is missing the voltage regulator. Can anyone show me a quick picture of where it goes? TIA
    • By NDV45
      I have  2008 Cub Cadet Volunteer Tracker.  Was running fine, parked and next morning electric fuel pump inop.  Checked voltage had 4.2 volts.  Swapped relays in fuse box, checked all fuses (good) and still low voltage.   Does the ECU control the voltage to the fuel pump or which relay controls the voltage to the pump?
      Have checked all wiring and not found any place it could be shorted (not saying I may have missed something). I am at a loss.  Need Help Please.
    • By Nathon S.
      I have a Bennche 700 EFI Bighorn. I’ve recently been unable to get it to start. After a little troubleshooting I realized my fuel pump was not pumping fuel. This weekend I emptied the gas and replaced it with new. I replaced the fuel pump, fuel filter and fuel injector. I also replaced the battery, spark plug and made sure all my fuses and relays were good. I have confirmed that the float on the fuel pump is not obstructed. The UTV is about 12 years old and has less than 100 hours on it. It has not run in over a year.  Not sure whats going on?!? After doing a little reading I'm leaning towards it being an issue with the ECU or perhaps a faulty wire in the wiring harness. Anyone have any ideas on where to start looking or what I could be dealing with? Any help is appreciated, thanks in advance!
    • By aefron88
      I've seen a number of requests for the location of all the grease points on these machines, and there is no definitive list in the manual. This covers the UT400, but other Coleman/Hisun models should be similar.
      Tools:
      First to grease your machine you need a grease gun and some NLGI#2 grease. You will find it helpful to buy a needle attachment as pictured here, due to poor clearance on some of the U-joints. The rest of the zerks use the standard attachment.
       
      Technique:
      Wipe any dirt/grease off the zerk before greasing to prevent pushing gunk inside and causing excess wear.
      Push the grease gun on the zerk at a straight angle and give it a few pumps. You will hear an oozing noise or sea grease coming out from the outside of the greased area when you've put enough grease in, a few pumps should be plenty.
      If it's just oozing around the zerk you either don't have a good seat with the gun, or the zerk may be rusted and the check ball frozen. Try seating it again and regrease.
      Wipe up any excess grease when youre done to prevent making a mess.
      Greasepoints:



      Rear A-Arms are greasable with the wheels on from the rear, I took the picture with the wheel off for easier visibility

       
      That's it. All other Hisuns should be substantially similar.
×
×
  • Create New...