Quantcast
Jump to content

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By NCPonyboy
      Hello, new Hisun Axis 500 owner here. I have a 2020 in the Mountains of North Carolina. It runs fine and I enjoy it but it seems to struggle on the hills. Granted I have one that is pretty steep but you could get out and walk faster than it goes up. I sometimes wonder that if I had anything in the bed it might not make it. So first question is, is this normal for these? Second question is, is there anything I can do about it? Maybe a power adder or chip tuning? 
       
      Appreciate your thoughts
       
       
    • By sxsadventurerally
      It’s time for the 10th Annual SXS Adventure Rally on the Rocks. Join us in the best sandbox this side of your childhood playground! Experience the thrill of exploration, the excitement of speed, the sensation of Mother Nature and machines.
      Come to gorgeous Southern Utah as the best industry Side by Sides and UTV's hit the sand, dunes, rocks and endless vistas of Sand Hollow State Park for the adventure of a lifetime. May is perfect riding weather and is sure to bring a smile to everyone’s face.
      This SXS/UTV family friendly event will overload the senses with professionally guided trail rides, rock crawling, camping, factory demo rides, rock crawling competitions, scenic rides, education classes, cornhole tournament, music concerts and more.
      Official expert guided trail rides are just $50 per person per day. Vendor areas, demo rides and entertainment fun open to the public with state park entry.

      YOU DO NOT HAVE TO ENTER THE EVENT TO COME ENJOY THE VENDORS AND DO TEST/DEMO DRIVES WITH INDUSTRY MANUFACTURERS.
      For more information and full 2024 event schedule and fees. Have questions? Hit the FAQ page: https://SXSAdventureRally.com/faq
      ~ PURSUE YOUR SXS/UTV PASSION ~
      REGISTRATION: https://SXSAdventureRally.com/registration
      Sponsored by:
      GBCTires.com – Presenting Sponsor
      Sponsorship and Vendor opportunities available. Please contact us for more information and bring your business to the true grass roots of the sport! 
      Instagram: https://www.instagram.com/SXSAdventureRallyOnTheRocks or @SXSAdventureRallyOnTheRocks
      Facebook: https://www.facebook.com/SXSAdventureRallyOnTheRocks

      For Additional Information, contact [email protected] or (435) 703-4444‬‬‬‬‬‬‬‬‬‬‬‬‬‬‬‬‬‬‬‬‬‬‬‬‬

    • By Nate ward
      Having issues with the IR model 421275 transmission. In 2wd it takes playing with the throttle to get it to engage in fwd or reverse, if you flip into 4wd, it goes into gear perfectly. Once moving, you can go back into 2wd and everything works until you stop. I changed hyd fluid and have ran the linkage in and out. Any thought on the issue?
    • By Hutch
      Okay everyone, need some help here. I got my 2014 Bennche Bighorn 700 from my father inlaw. He has had it since new and as far as I know never had any problems with it until recently. It began with it being hard to start and having to give it some throttle for it to start up. Then it wouldn't stay running once it did start. If you go to start it, it will fire right off and only run for a split second and then die. If you give it some throttle it will start and stay running as long as your foot is on the pedal. While it's running its pretty rough and backfires. Here is a list of everything I've done so far. Initially I checked compression and it was low. I changed the cylinder, piston and rings. Took the head apart cleaned and laped the valves. Checked timing a few times. Adjusted the valves. New spark plug. Checked the air filter, it was fine. New battery. Changed the fuel pump because of a broken fitting. Changed the fuel filter, lines and fuel injector. Dumped the old fuel and put new in. Changed the air idle control, TPS, MAP sensor, Voltage Regulator, ECU and harness. I was getting codes 31, 107, 113 and 122 on the display. Once I changed the ECU no more codes have been displayed but still have the same issues. All fuses look good and as far as I can tell Grounds are good unless there are some I can't find. I'm at a loss here. Not really sure where to go. Compression was better after everything I did but I don't remember the numbers. I'll have to check it again if someone thinks that could be the issue. Any help would be greatly appreciated!
    • By Working hard to hardly work
      So... I have just finished rebuilding the 500 (bought it with low compression).
      The rebuild was successful runs great. But, I'm not circulating water. I've been trying to read through the forms to figure this out and I'm going through the process of trying to bleed or replace my water pump either way there is a hose barb. 
×
×
  • Create New...