Quantcast
Jump to content

Recommended Posts

Hey guys we purchased this for a 2013 RZR800S and decided to not use them , going a different direction

The price is 1995 plus freight for these

will do $1599 Shipped to your door

these are brand new never installed

Please PM me if interested..

post-2266-0-34799000-1409763016_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • What weight of oil and brand Joyner 1100

      What is a good oil for the 1100 just bought it and wanted to know what weight of oil and brand?

      By Monty Herbold, in Joyner UTV SxS Forum

      • 8 replies
      • 521 views
    • LED light bar 🔥Promotion Best Price 🆕🆕

      MICTUNING LED LIGHTING  offer free led light bar  Follow  MICTUNINGLEDLIGHTBARS  on Facebook  

      By Jeremy SK, in UTV Product Specials and Promotions

      • 5 replies
      • 1,030 views
    • My Joyner parts prices will not be beat! price matching plus 5% off!

      All you need to do is show me a lower advertised price. I will then match and beat it by 5%. Don't waste time and get your parts from the source with the best guaranteed prices!

      By JoynerUSA, in Joyner UTV SxS Forum

        
      • 5 replies
      • 558 views
    • Brand new trooper Intermittent starting issue

      I've had a 2016 trooper for a few months, it's never worked properly.  I'm about ready to take it to a dealer for warranty work but it's a little far so I'm trying to avoid it.  It on occasion will not start. It took a while to figure out that if I open the throttle just a little bit it will fire, I then have to hold it open for anywhere from five to thirty seconds for it to idle on it's own.  Other times it fires right off no problem.           It's turbocharged, and has two pumps.  I've verified that the fuel pressure is correct.  Joyner has had me swap a bunch of parts to eliminate them.  I suggested it seems that possibly the IAC is malfunctioning or that it's getting incorrect inputs from the tps but they disagreed.  I've read that people have had similar issues stemming from the IAC but until I get a replacement from them I can't verify.  I tried setting base idle a little higher with the set screw but the idle just gets erratic and won't idle down once I've given it some throttle.          I'm going to call them again tomorrow and have them send a new throttle body to try, and I also have a scanner for European cars coming that is supposed to read chery automotive ecu's; after that it may be time to haul it in.  Anyone else had a similar issue?

      By Darryl223, in Joyner UTV SxS Forum

        
      • 14 replies
      • 588 views
    • Are you interested in moderating?

      We are looking to add some new moderators to our forum, to cover our manufacturer specific forums. The requirement is that you own that specific UTV and are a forum regular or plan to be. The forums we are looking to cover are: Arctic Cat Prowler Forum Kawasaki Mule Forum Kawasaki Teryx Forum Polaris Ranger Forum Polaris Ranger (RZR) Forum Yamaha Rhino Forum Honda Big Red Forum KYMCO UTV Forum If you own one of these, are a forum guru, and would like to try a hand at moderating..let us know by replying to this topic. Thanks.

      By Alex, in UTV BOARD Announcements

      • 7 replies
      • 3,574 views
  • Similar Tagged Content

    • By Markus_K
      Hi everyone,
      Been driving my Massimo since January. Really pretty satisfied with it. I have done 1 oil change on it and have now over 1700 miles on it. I have one leaking seal on the axle at the diff, but that is pretty much it. I do have a curious thing that happens occasionally. When turning or coming in or off a trail at a pretty severe side angle, I get an occasional snapping sound. This sound is pretty loud  and can be felt in the footwell area. It doesn't seem to really affect anthing and there is no obvious or easily seen area where some kind of movement is happening. I'm wondering if the leaking diff seal is related to this popping sound. Could the axle be pulling out of the diff?
      Thanks for any help
      Mark
    • By TimmyBoy
      Polaris XP 1000 Turbo front and rear stock suspension, good condition, no ball joints in a-arms, take offs, installed LT kit, will separate front and rear but will not sell just part of front or rear

    • By sackspeed
      Hi Guys - we have a Joyner Python 800i which we use offroad here in Scotland.

      The standard shock absorbers we can get in the UK are only lasting a few days and we are struggling to find uprated ones which will fit straight on - can anyone advise on good replacements or send me a link please ?
      Thanks
      Alan

    • By nrm5108
      I got a full set of King 2.0 shocks in great condition. They were just serviced 100 miles ago so they are still very fresh. The set also comes with a extra set of rear springs that are a little bit softer than what is on it now. Looking to get $1400 but I am open to any offers.




    • By hfrick
      just doing some research on different shock options...I have read the other topics relating to shocks...has anyone actually recorded the wieghts,travel etc for the stock t2? how about a renegade r2 ? thanks Hardy
×