Quantcast
Jump to content

Hunter

Help I got a mule 1000 450 1988

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By jgreg
      Hello.  I have 2006 kawasaki mule 3010 trans 4x4 that has the drivers side wheel turning inwards while the passenger side is straight.  What would cause this to happen and what would you suggest to repair.  Thanks.  Adjusted the tie rods, but wont fix this.
    • By Travis
      It's been leaking VERY slowly over the past couple years, just  had to add a minute amount of brake fluid every few months. Now i have to i add about 3/4 of a cup every 5 days.
      i took the rear tire off, where it is leaking from, cleaned up the outside of the drum and it looks like the fluid is leaking from where the   "outer" drum meats the inner drum, #41038. guessing its the brake cylinder inside..... any other thoughts. I made sure the brake line is tight too.

       
    • By southwestvawildcat
      So I just bought a 2012 Wildcat 1000.  When I bought it, it was throwing the code P0500.  I followed suit and replaced the speed trigger and speed sensor.  The speedo and odometer still didn't work.  I went ahead and cleaned all connections including to the LCD gauge.  This past weekend, we rode and at acceleration I continued getting the P0500 code along with C1312.  After riding a couple miles, the speedo starting acting crazy and then all of a sudden worked.  I found after I cut off the machine, on restart, back to the codes until I rode a couple miles.  Any help on how to fix this issue would be greatly appreciated!  Thanks in advance.
    • By Muledaze
      Dipstick shows pale color, dont think its water, smells like fuel, oil changed one week ago, level is very high.
      First I thought it was water condensed into the oil...but someone pointed out the smell, and it doesn't look white-milky. And a half qt or so in one week?
      So is it possible to get fuel leaking into the oil?
       
       
    • By bbbv4711
      New here and have a question.
      I have a 2009 Arctic Cat Prowler 1000, I am wondering if other year engines will work on the 09? Looking at part numbers the engine has the same part number for 09 and 10, then 11 to I believe 15 have a different part number.  When looking at rebuilt engines some one stated  that theirs would fit Prowler 1000 09-15. So I thought I would ask.    Thanks in advance


×
×
  • Create New...