Quantcast
Jump to content

charlie

wheel HUB

Recommended Posts

hey guys has anyone replaced there front wheel hubs or brake hat if that what you wanna call it. Im talking about the splined part the axle rides in and the wheel studs press into. Im trying to get rid of the play in the front of my trooper. My axles are not damaged looking for opinions

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dan B
      I'm in need of a brake master cylinder for my ride.  Appears to be leaking between the reservoir and the cylinder (picture).  Is there a seal that I can replace inexpensively without buy a whole master cylinder assembly?  Can't tell if the master cylinder is the same as used on the Trooper because I don't have a Trooper parts manual.  I don't know if the master cylinder is different when they went to the 1100cc engine.  Has anyone had experience with master cylinder make for the Kinrod Joyner line of rides (I believe it's a German company)?  They are available on Amazon but the configuration isn't the same as OEM.

    • By M C
      Hey guys just bought a 07 trooper. Previous owner stated it ran great etc prior to clutch job then had issues. I drained tank, replaced plugs etc. found one of the injectors connectors was not connected and plugged it in. Solid 50psi fuel pressure.  It starts easier than previously on 3 cylinders but still runs very very poorly. I’m thinking the sound I’m hearing is it detonating at around 3k. It kinda sputters and falls apart. Sounds like clicking or something when it happens. I am at a bit of a loss, compression is a solid 150psi across the board with no movement. Verified spark and now am assuming all injector are functioning more or less correct as if I unplug any one it sound terrible at idle. 
       
      A note, I tapped plugs at .7 manual called for .9-1.1 but that seems super over doing it but I will try adjusting them to 1.0
      additionally I’ve noticed the fan in rear doesn’t turn on. 
       
      anyone with any help I will be in your debt.
    • By CYJSP2009
      Anyone who want JOYNER  CV Joints. or CV AXLE  please send email to  [email protected]  before NEXT MONDAY ( JAN-18  Chinese TIME)
       I will collect demand before this time and confirm to who send email whether I can arrange production. 
      Thanks 
      P.S.  Also welcome checking availability of any other Joyner parts, 800 CC  and 1100 CC  Chery engine parts  (  these does not has time limitation) 
      Casey / Leaf  Asia
      2021-01-14
       
    • By Jim Sabin
      I have a 2012 MSU 500 that recently was having an issue with the motor not starting,  I ended up reworking the ground wire at the fuel pump leads and now I have notice that when I switch to 4Wheel drive, it does not work. Any ideals what going on?
    • By Gorj
      Do not know if any of you Hisun E1 owners have  had issues with the parking brake pedal  not returning completely, thus preventing you from moving forward or reverse.   I had this issue and even sometimes when going over rough road the parking brake pedal would move down far enough to shut off power.  Local  dealer said no one had complained about that issue and they had no fix.  So decided to correct it myself. I installed a return spring on the parking brake arm and it stopped the problem!



×
×
  • Create New...