Quantcast
Jump to content

charlie

Help clunk noise turning left

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Jim Sabin
      I have a 2012 MSU 500 that recently was having an issue with the motor not starting,  I ended up reworking the ground wire at the fuel pump leads and now I have notice that when I switch to 4Wheel drive, it does not work. Any ideals what going on?
    • By Heath Herring
      I have a 2014 4010 trans 4x4 (KAF620REF). Are the rear left and right driveshaft assemblies the same part number? I ordered the two sections individually for the rear right & they are coming up too short in length. Possibly the wrong parts ordered by the dealer? Thanks in advance.
    • By silverbullett
      Just purchased a 2020 Pro DX  with Yanmar diesel. Had a 2007  3010 Trans Diesel I traded in. My problem is that the new machine is so much noisier  than my old one.
      Has anyone had any luck in quieting down the noise? Sound proofing.?...changing the exhaust routing.?...the muffler? Any ideas or solutions would be appreciated.
    • By Waleygator
      New machine, tilt wheel won't "tilt" and I don't want to force anything.  Owner's manual says to pull pin, adjust, release pin in desired position.  I can feel the pin moving, but wheel won't lower.  Any suggestions instead of taking it all the way back to the dealer?  Thanks in advance...
    • By Chad Rice
      HELP - my wife and i just bought a 2013 joyner trooper 1100 and we rode for 2 evenings with no problems. Went to ride last night and all of a sudden it acted like something was catching up and it didn't want to move easily. Whatever it was must've broke and now it moves with no problem but is making a rubbing/grinding noise somewhere in the backend. Could it be wheel bearing, differential, or something in cv shaft. Any info or similar experiences is appreciated. 


×
×
  • Create New...