Quantcast
Jump to content

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Kmrider
      Tried to buy a 2020 Kawasaki Mule Pro FXT and was told their was a stop sale on them, but the dealer had no info on what the problem was or how long until a solution is found to whatever the issue is.   Anyone know anything about this?
    • By chris.minix
      Is the any other ball joint brands out there for the Troopers? 
    • By Lenny
      I'm not trying to trample flatbeds post about the front ball joints being able to pull out. I just couldn't find his post to reply there. Sorry flatbed. Flatbed found that the bolts holding the ball joints in place weren't close enough to the ball joint stem to fit into it's groove, thus the ball joint could work it's way out. This happened to flatbed and Kinarfi. It could be very dangerous if this happened at the wrong time. I finally got around to checking mine today. The top of the ball joint on the front left had already pulled out 1/8". The bottom one was still ok. I did as flatbed sujested and drilled them out and refitted them with new bolts. Both joints on the right side did not need any work as they were secured ok by the original bolts. To reiterate what flatbed said, be sure to address this potential failure. Just redo them and don't wait for signs of them pulling out.
      Lenny
    • By TmJoyner
      New to the Joyner community.  Bought a used 2016 1100 sand viper in descent shape. Only 155 miles.   Runs great.  It just rattles quite a bit in the front when riding on rough gravel / hard-packed dirt roads outside St Johns.  Removed front wheels and seems to be coming from both upper and lower suspension arm bushings/radial bearings (see pic); both left and right.  Seems like some play inside the eyelets - as I shake the arms a bit.  I assume it's not supposed be loose in there like that and the bushing/bearings are worn.  Anyone have had this issue and how did you go about changing them?
       



×
×
  • Create New...