Quantcast
Jump to content


2009 mule 610 keeps blowing fuses


Recommended Posts

my 2009 mule 610 4x4 keeps blowing the main fuse. the dealer said a controller needed replacing and it was not cheap. it cranks up and after

about a minute the oil light will come on and then the fuse blows.

kind of a novice when it comes to diagnosing electrical problems.

has anyone had this same or similar problem. Or, do you know anyone that has.

any help will be appreciated.

Link to comment
Share on other sites

  • 1 month later...
  • 4 years later...
  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By packersfan
      I have a hisun 500 got from a auction and when turning a corner left or right it's a two hand job then when you left go snaps back.any help on what to look at would be appreciated.
      Also blows blue smoke until she gets warm then it's ok 
    • By TimsBrickHouse
      DO NOT BUY ANY THING FROM HISUN Period! I had the axis 700 for 2 months when a rat or squirrel ate both wiring harnesses. (Main & ECM)Wanna know why? Because the manufacture of these things in their infinite wisdom use either, a soybean oil or a peanut oil to run the wires through the the wire loom. Hmmm i wonder why they would be inclined to eat the wires. So now I have $10K machine that I've only had for 2 months when all this happened and they will not warranty it at all. It is going to cost me $800 to $1000 to get this fixed. Here is a link to a video showing where we took our Hisun notice how many are there:
       
      https://photos.app.goo.gl/2FdniAoCyvTJMKae7
       
      So counting mine, there are 16 of Hisun Axis on the lot that i took in for authorized dealer, with the exact same problem, plus other troubles that the mechanic explained to me. This particular place told me they are not going to work on them anymore. I will be posting this in as many places as possible to reach the masses. I hope its worth Hisun!
    • By Spider
      My touch screen shuts off and turns back on while driving. Is there something I can check or do to try and fix it? I have a 2022 T-boss 550x with about 7 miles on it. thanks
    • By BuckSlayer
      I have a 2017 Trail wagon tw450 two wheel drive with a Kohler motor when I'm driving long distance it shuts down and under a mile pull over it stays running and you can take off and go a half mile and it shuts off again. I can't find what's wrong with it can somebody please help
    • By TapBoss
      So I'm out a deer camp and ran the sxs for 2 days.  The next morning, fired it up and headed out.  Made it about 50 yds then bogged down and died.   Restarted twice and only moved a few feet then would not restart.  Took the truck out for the day to hunt and when I got back I could hear the fuel pump kick on when the key was turned but it would still not start.  Added stabilizer to the fuel and put the trickle charger on it and tried again the next day, still the same - pump coming on and turning over but no start.  Other than spark plug, air filter or injector clog any ideas?  Out in the middle of nowhere so limited on resources.
×
×
  • Create New...