Quantcast
Jump to content

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By 2wpuller
      Has anyone replaced the stock shocks and springs on their 2015 Dominator 800 X2 to ride alittle smoother are just changing the springs out.I gotten alittle spoiled riding in my son's rzr 1000xp.
      My wife just made a comment why don't ride as smooth as our son's thing.lol
      I'm 62 she's 61 the little rough ride doesn't really bother me. I drive a concrete mixer for a living. 
      I really like the Odes it's pretty good power for for only 800cc
      I took off the cat and the stock muffler. Put a glasspack with 2" inlet and outlet it has a good deep tone and not really very loud. I'll find out Sunday when we hit the woods .It's definitely more peppy. 
    • By Joel Goldsney
      2009 Hisun 700.... previous owner did a number of changes. This part is under the driver's seat but not attached  to anything.
      Is this the old fuel pump?
    • By tazzplay0228
      Hi all. 
      Im new to the utv world. I just bought a 2014 Odes Raider 800. It has only 10.2 miles but has been sitting awhile. I want to change oil and front and rear differential oil. Cause it still has what ever they stuck in it from the dealership. Also what gas rating should I run in it.  I figure mid or high test fuel.  I downloaded the manual for it but it does not say what gear oils or or oil it runs.  Thanks for any help and input. 
    • By GDS
      I have just purchased a 07 3010 Mule. It has high hours at 1900 but has been well taken care of. It seems to run well but just a bit weak. Every now and then I hear a clinging sound that may be a ignition spark to ground but I can't seem to find it. It will not do it when I'm looking. Also the back plug is showing its rich. It is black in no time where the front is a lite brown. 
      I did find it had the wrong plugs so I changed them, but no help. 
      As I have just got this I was wondering what do I need to look at as far as simple mods or weak points. 
      Thanks for your help
    • By Alex
      Get ready! We're bringing the world‑renowned Nitro Circus to the Glamis dunes for not one, but three exclusive boundary‑breaking shows!   This is a Camp RZR you don't want to miss.   By pre‑registering, you get reserved access to the show and are automatically entered to win one of the Grand Prize Giveaways!   Pre‑registering will get you on the list, but be advised that the first 100 people to check-in at Camp RZR Friday, October 25th will get closest to the action with premium viewing for the Saturday night show.   Learn More   Register Now     RZR Vehicles Shop Accessories Shop Apparel Explore All Off-Road Vehicles                            


×
×
  • Create New...