Quantcast
Jump to content

jjmccartney7

2013 odes dominator 800 rear cv axle

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Chad Rice
      HELP - my wife and i just bought a 2013 joyner trooper 1100 and we rode for 2 evenings with no problems. Went to ride last night and all of a sudden it acted like something was catching up and it didn't want to move easily. Whatever it was must've broke and now it moves with no problem but is making a rubbing/grinding noise somewhere in the backend. Could it be wheel bearing, differential, or something in cv shaft. Any info or similar experiences is appreciated. 
    • By Travis
      Some of us have had our Side by Sides for a long time and some of us for only a few years or months.... They say hindsight is 20/20 and in that case if you could go back and purchase a different UTV brand that would be better, would you?
      after you've answered, comment below on why you may or may not choose differently
       
       
    • By justingrider
      Good morning everyone, appreciate any help on this.  I picked up a 2013 Hisun 800 for a project.  Previous owner had fried a lot of the electrical with a bunch of aftermarket audio equipment, so I have been replacing all of the wiring to give it a fresh start.  I'm 95% there with a couple of plugs I can't figure out where they need to be routed and the reason for me reaching out for help here.
      1.  A female 2-port white plug that comes off the end of the main harness, close to the side where the terminal hook ups tap into the battery.  It has a Blue/black-stripe wire and a White/blue-stripe wire. (Pictures: https://ibb.co/m9PRDqX and
      https://ibb.co/9pHZsFj). I'm assuming it is another single offset fuse or module like the other pieces around it but can't find anything on what it might be or that wire color combination in the manual/wiring diagrams...anyone know what this guy goes to?
      2.  On the crank position sensor (torque sensor), the wires that I have coming off of that are a green wire and blue/light-gray-stripe wire (https://ibb.co/FmJLJfs)...any idea on where this guy is suppose to plug in to?
      Again, thanks for any help you can provide!
      -Justin
       



    • By tazzplay0228
      Hi all. 
      Im new to the utv world. I just bought a 2014 Odes Raider 800. It has only 10.2 miles but has been sitting awhile. I want to change oil and front and rear differential oil. Cause it still has what ever they stuck in it from the dealership. Also what gas rating should I run in it.  I figure mid or high test fuel.  I downloaded the manual for it but it does not say what gear oils or or oil it runs.  Thanks for any help and input. 
    • By Seth Zora
      I recently acquired a 2010 Wildefire WF-300 UTV. I'm trying to determine if this is actually a hisun utv or another brand. Has anyone heard of this name or can point me in the right direction?


×
×
  • Create New...