Quantcast
Jump to content

Old Outlaw

Dyno Boost Module

Recommended Posts

Has anyone tried the "Dyno Boost Module" ?  I would like to get a little more power from my Massimo 500.  Input?  Parts suppliers?  

Share this post


Link to post
Share on other sites


Has anyone tried the "Dyno Boost Module" ?  I would like to get a little more power from my Massimo 500.  Input?  Parts suppliers?  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By 2017 Massimo Warrior
      ABSOLUTELY THE WORST EXPERIENCE EVER!!!!!
      I purchased a Massimo Motors Warrior 700 UTV directly through the company. This unit was listed for sale on Ebay as a company demo with only 77 miles. Prior to bidding on the item, I messaged them through EBay and asked if there was "anything wrong with it and if everything worked properly". I was assured in writing that everything on the UTV was operational AND that it would be inspected before shipping. I also called the number that was in the EBay listing to verify that everything was operational and to make sure the item could be delivered to my land in Missouri. I made it VERY clear that I was not interested in bidding on the item if those two things were not acceptable. I was assured over the phone that everything was operational, that it would be inspected prior to shipping and that delivery to my land in Missouri was perfectly fine.
      It was not delivered to the address agreed to by their contact listed in the EBay listing. And when it was received, there were multiple items that were not operational. Items that were defective when it arrived include a headlight, a backup light, both horns, the horn wiring and the parking brake.  They refused to even supply me with replacements for all the defective parts. In response to the BBB, Dave said it was sold without a warrantee.  The listing very clearly stated 180 day warrantee for parts.
      In addition, the windshield that was clearly shown on many photos on the listing was not delivered with the UTV. That's correct...THEY STOLE THE WINDSHIELD before shipping the unit to me. The first representative from Massimo Motors told me multiple times that “the company will make things right for me”. He did supply me with a couple parts; which I installed myself. Later, he told me that he is no longer with the company. Dave, the new contact never offered any reasonable solution to any of the remaining issues.
      His solution to STEALING THE WINDSHIELD was for me to fabricate one myself.
      Unbelievable experience. See files attached.
      Hope this helps others from making a BIG MISTAKE.
      See photos attached for proof.
      If this help, please let my “buddy” at Massimo know why you aren’t buying one.  Here’s his info:
        [email protected]




    • By Andreas Ahrens
      Hi All,
      Our Hisun is not making any power. Once you start to climb RPM's it almost sounds like the timing is out, it sputters and farts and doesn't want to climb RPM's at all. It starts fine though.
      I checked and set the valves, they were a bit tight but not bad. The spark plug is very black. The exhaust valves are a real nightmare to get to fyi.
      On the last service the dealer put the wrong plug in, so I'm switching that back to stock as soon as we get one. I'm also thinking the air filter should be checked/cleaned. 
      Any other things to check?
    • By Joe Breaux
      Got a 2017 Massimo MSU500 UTV with thermostat malfunction.. hot light comes on in 4-5 minutes but radiator is ice cold... where exactly is it?  The hose neck on the head has nothing in it.  I was told it was down by oil drain plug.. only thing I see is water pump.. Is in inside pump housing?  Cant find any exploded diagrams that show it.. how to I remove it? any help would be appreciated
    • By Richard Schleper
      I have a new Buck 400 with about 60 miles on it. It runs great but can only get it up to 23mph. Is this normal? If not what speed are others gettting.
    • By Paul R
      I have a new Massimo T boss 410 with 2 hours on it. I tried to start it today and I get no power at all. I tried jumping it and still no power sounds electrical problem. Any help would be great 


×
×
  • Create New...