Quantcast
Jump to content

Help with Limited Slip


GDS

Recommended Posts

I have a Brush Hog TH420 side by side and having trouble with spinning one tire. The other tire will kick in but only after you spin like hell and dig a hole. The final drive /gearbox is a Comer Industries out of Italy. The part number is 9.485.003.00, SN 0082, Date is E04.  I can find a parts breakdown. When you bring up the transaxle it shows the internal differential but no breakdown. It does say see diff assembly but there is no diff assembly.  I'm not sure if this type is no some other side by side. 

0715191459.jpg

Link to comment
Share on other sites

With the older cars with limited slip rear ends you had to use certain fluid. It might be the cause of your problem.  Has it ever been changed?  How many hours, miles since the last change?           Manual says to use and change the transaxle fluid.                                                        Mobilube HD LS 80W-90  (or equivalent)                                                                                                                                                                                                                                         https://www.manualslib.com/manual/878997/Bush-Hog-Th420.html?page=54#manual

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By doncaron
      Hello everyone! 
      First of all I would like to thank you for the help with my timing problem, it was the chain. Now I’m looking for the part number for the wet clutch baring.  I’ve been looking for it but my side by side is a 2022 t-boss 550 and it’s not the same as a 2021. Can anyone help me please?
      thank you in advance again. 
       
    • By Taz
      I am looking for the front brush guard that was made by Off Road Body Armor.
      They stopped making it to fit my 2023 Kymco 450i..
      So if anyone knows where one is I would like to buy it.
      Thanks Gary
    • By Steve B
      My "R" light on the dash will not go out when I take the UTV out of reverse and put it into any other gear. Is this just the light switch issue or will this effect engine performance in the other gears?
    • By Hugh
      My 2018 Hisun sector crew engine cut off after about 15 minutes run. There is no indicator of what is wrong, no error code just die and won't restart until it cool down. I notice that the fan is not running but the temp indicator is on low temp, no overheat indicator. I checked the radiator fluid, it is cool to touch.
      Cooling fans are working, I can hear it running once awhile if I can get the engine warm up enough.  Thank you for all the help.
       
      Hugh
    • By Richard shepard
      I have a 2021 colman 400utv engine will start and idle, as soon as you hit throttle to move engine dies and will only start when you throttle it, let off throttle it dies, I replaced the injector and plug still the same, anyone have any other ideas
×
×
  • Create New...