Quantcast
Jump to content

American Star Mfg ATV and UTV Components


americanstar
 Share

Recommended Posts

Hello Forum Friends... 

We are American Star Manufacturing LCC - a manufacturer, distributor, and retail seller of ATV and UTV suspension components, OEM replacement parts, and accessories. We carry a full line of ATV and UTV A-Arms, swing arms, tie rods, tie rod ends, tie rod rack kits, ball joints, wheel bearings, braided steel brake lines, billet aluminum accessories, and much much more.

Our new Talon 1000R 4130 Chromoly Aircraft Grade Steel Rear Sway Bar Links are as shown in the attached photographs.

Telephone: 435-562-4386

Email: [email protected]

Talon R Illusion Orange FB.jpg

Talon R Illusion Red FB.jpg

Talon R Illusion Sour Apple Metallic FB.jpg

Talon R Pearl Black FB.jpg

Talon R Very Red FB.jpg

Talor R Illusion Blueberry Metallic FB.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By malenurse13
      We just bought a used 2017 American Landmaster TW450. No hour meter that I can find, so not sure exactly how much it has been used. 
      The first 2 days we had it, the starter was a little sketchy, but it started after 2-3 tries. Sometimes when turning the key, we would hear a loud metal "clink" sound. Like the starter made contact, but didn't have enough power to turn. 
      THIS MORNING... Turning the key, we hear a single click sound. That's it. Even with a new battery, the starter is still doing the same thing. Both batteries (old and new) were reading 12.8 volts on volt meter. So I'm wondering what else could be going on? Any ideas on what to look for would be greatly appreciated...
      Thank you!
    • By Robby
      Hello, I have a 2013 500 utv hisun. Was running ok and cut out while parked. Bike will not start now. It turns over, but won't fire. I have no spark and no fuel. I replaced fuel pump, ignition coil, spark plug, cdi, voltage rectifier and all the fuses and relays. Could bad stater cause no fuel because I can't hear the fuel pump priming. Any info on where to start looking for problem.
    • By Steven78
      Hi I have a t boss 410 is about a year old with 150 MI and it feels like the brakes are stuck when you take off but in neutral it rolls perfectly I also have a t boss 550 that does not do this so was just wondering if anyone else has had this issue or if it is common with this machine also on the 410 have had the stator motor and voltage regulator replace once already and think it is bad again not sure if this would have anything to do with the other issue any help or advice would be greatly appreciated thanks in advance
    • By Kyle Krause
      What a great time at this years White Mountain UTV Jamboree... go to www.utvoffroadadventures.com for all the upcoming UTV Events all over Arizona!
       
    • eManualOnline
    • By johnpeter
      2017 Yamaha YXZ 1000R SS Limited UTV Side by side Sport shift On Ebay
      https://www.ebay.com/itm/203598263204?


×
×
  • Create New...