Quantcast
Jump to content

Dozerdeano65

New member

Recommended Posts

Retired not in the best of health and decided to have a little fun. Bought a 2015 Yamaha Viking 700 camo edition. Has hard cab with doors,wipers,heater. Was wondering will 2016 6 seater front quarter doors work on a 2015 3 seater? Both are Yamaha Vikings. Thanks 

Share this post


Link to post
Share on other sites


Welcome to the forum!

Look up Pacific Eagle UTV, they have tons of enclosures for utv's and a discount for members of this forum. They may have what you are looking for.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By 2wpuller
      Just finished getting the 30×10×14 on today. My soninlaw had them on when I got home from work. It was raining this evening couldn't go for a ride. The front rubs when they are turned.I might relocate the A arms forward a couple of inches. To get the clearance needed. Sure makes the machine look different. It has the short A arms



    • By Jonathan Wallace
      I have 2015 can am maverick 1000r xds turbo. It sat for a month and everything was fine when I parked it. I went to start it last weekend and the check engine light popped up and the check DPS code scrolls across the dashboard.
    • By johnpeter
      2017 Polaris 1000 4 seater Turbo  On Ebay
      https://www.ebay.com/itm/2017-Polaris-1000-4-seater-Turbo/224228870318?

       
    • By David Trost
      2017 model.    I have checked the wiring, and even replaced the fuel pump.    The gauge still doesn't work.    Thanks!
    • By Brad G
      Timing chain broke. Replaced the timing chain, oil pump chain, cam & rings. Ran great for 2 hours. Brought it home, started & drove to the shop. Next day started & drove around the property and it started running rough, wouldn’t idle just died, restarted & took it to the shop. Next day wouldn’t even start just crank over. Drained all the fuel & replaced with new, bought a new plug & ecu! Fired right up and let it run for an hour & burped the coolant as I had double checked the timing & valves prior. Next day started it and it was running a bit rough but smoothed out & ran for another hour. Next day it just cranks & won’t start! I’m at my wits end with this machine and would appreciate any help or suggestions on what might be the issue. Thanks in advance! 
       
      Brad


×
×
  • Create New...