Quantcast
Jump to content

Recommended Posts

I have a 2011 700 nordik with all new brakes and rotors and master cylinder. My problem is the back brakes are making a noise just like when brake pads and worn down to metal on metal.

Share this post


Link to post
Share on other sites


Now I have one more problem , the caliber stayed partly on and turned the rotor got red and caliber got hot enough it blew the brake line.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Gorj
      Do not know if any of you Hisun E1 owners have  had issues with the parking brake pedal  not returning completely, thus preventing you from moving forward or reverse.   I had this issue and even sometimes when going over rough road the parking brake pedal would move down far enough to shut off power.  Local  dealer said no one had complained about that issue and they had no fix.  So decided to correct it myself. I installed a return spring on the parking brake arm and it stopped the problem!

    • By Susan Thompson
      Hi everyone, new to UTV life. My 2010 500 EFI has problem with re setting  maintained light and also hour meter. Have read manual and cannot find out how to re set after oil change.
    • By Kyle
      Hello fellow hisun owners, I'm new to the Forum just wanted to ask a question about my hisun 800, I currently need to replace the crankshaft position sensor but due to my location I'm looking at almost two months before I see one, I was just curious if anybody knows of another brand that use the same crankshaft position sensor for the hisun 800 motor. Like Polaris, Yamaha, Suzuki, or even automotive. Thanks. 

    • By Kelly Stump
      Just put new rings in my joyner trooper 1100 and it still smokes. I dont know what else to do. Can some one tell me why?
    • By Andreas Ahrens
      Hi All,
      Our Hisun is not making any power. Once you start to climb RPM's it almost sounds like the timing is out, it sputters and farts and doesn't want to climb RPM's at all. It starts fine though.
      I checked and set the valves, they were a bit tight but not bad. The spark plug is very black. The exhaust valves are a real nightmare to get to fyi.
      On the last service the dealer put the wrong plug in, so I'm switching that back to stock as soon as we get one. I'm also thinking the air filter should be checked/cleaned. 
      Any other things to check?


×
×
  • Create New...