Quantcast
Jump to content

2015 hisun strike issues


Quade

Recommended Posts

This is my first UTV and it ran great the first 500 miles. Then it slowly got harder and harder to start. Now I have to keep giving it gas when I first start it for about 1 minute until it will idle by itself. This past weekend I took it on the trail and it died 15 minutes into the ride and lost all spark. I got towed home and tried to see if I had spark the next morning which I did and it started but died 10 minutes later. Anyone have any ideas what I should do or check? Anything would help thank you!

Link to comment
Share on other sites

  • 2 months later...
  • 1 year later...

Any help would be appreciated. I have a 2015 strike 1000 crew I just bought and it was hard to get it started. Having to pump the gas and rev it several times to get it to idle. I pulled the fuel pump to check for and clogs or dirt and when I put the pump back in now it cranks easier and idles but lost all power. Barely reaches 20 will no spin a tire on dirt.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Hi sun 500
      hello everyone, i just joined this forum to try my luck, few days ago i bought an old (dont know exactly), 2011/14 hi sun 500cc ""carburated"",  was not running at the time, but i fell was a good deal and decided it to bring it home to play with it, this is the issue, i bought and installed a new carb, and pump, i repositioned the battery location and upgraded to a "car batt", reconnected the fuel lines and started it, but it only runs with the choke ON, i checked the bowl, it does have fuel,but for some reason wont inject it to run, i came across a video that say that ""the body small tank had to be connected for the cart to run" (was deleted when bought), sure enough i got it to run sporadically , but the so called ""small body tank'' often runs out of fuel and wont refill itself , i had to couple times do it manually, so how does that small tank works ?..what does it do?..and why if  bypass it , the cart wont start?....any help?..thanks so much!!!
    • By malenurse13
      We just bought a used 2017 American Landmaster TW450. No hour meter that I can find, so not sure exactly how much it has been used. 
      The first 2 days we had it, the starter was a little sketchy, but it started after 2-3 tries. Sometimes when turning the key, we would hear a loud metal "clink" sound. Like the starter made contact, but didn't have enough power to turn. 
      THIS MORNING... Turning the key, we hear a single click sound. That's it. Even with a new battery, the starter is still doing the same thing. Both batteries (old and new) were reading 12.8 volts on volt meter. So I'm wondering what else could be going on? Any ideas on what to look for would be greatly appreciated...
      Thank you!
    • By packersfan
      I have a hisun 500 got from a auction and when turning a corner left or right it's a two hand job then when you left go snaps back.any help on what to look at would be appreciated.
      Also blows blue smoke until she gets warm then it's ok 
    • By nods
      Less than 40 miles can barely start. Dealer is working with Hisun on a number of other issues on this UTV. Can not get clear info on the meaning of these E codes this is getting. Anybody have some clear info for me?
    • By Chucky 1
      I purchased a new 2023 Landmaster UTV L4 in October of 2023.  UTV didn't seem to have as much power of the demo L4 that I drove but figured once it broke in it would be better.  After about a week the unit started bogging down backfiring and stopping.  Gas fumes really bad, wait a few minutes and it would start up again.  Brought it back to the dealer and after keeping it for a few weeks said he couldn't find anything wrong with it.  Got it back home and it started acting up again, brought it back to dealer a week later and he said he found couple things that might cause it to do run bad and he was able to replicate the issue but didn't really know what was wrong.  Got it back home again after being at dealer for several weeks and the unit started running bad again right away.  Brought it back to dealer and he went back and forth with Kohler about possible fixes but just checked somethings and try to swap a few parts but still runs bad.  I called Landmaster HQ to speak with someone about a refund and was told that was handled at the dealer level.  Dealer called Landmaster and they told him they didn't do refunds or exchanges especially with units that had problems.  The dealer is now trying to get a new engine to but I have not heard anything as of yet.  I did file complaint with Better Business Bureau and they accepted my claim and reached out to Landmaster.  The National Service Manager called me and said the he had been contacted by the BBB about the complaint and he would look into it.  I told him that I would just like to have my down payment of $2,000.00 returned and never mind the over $1,000.00 I have paid in notes for a UTV that I cannot even ride on without hoping it gets me around the neighborhood.  I have found out that the 2024 Landmaster UTVs will have Vanguard engines due to issues with the Kohler engines.  Very disappointed in what is "Proudly Made in the USA" and the way Landmaster has treated this disabled veteran! 
×
×
  • Create New...