Quantcast
Jump to content

Susan Thompson

Problem with 2010 Polaris Ranger 500 EFI

Recommended Posts

Hi everyone, new to UTV life. My 2010 500 EFI has problem with re setting  maintained light and also hour meter. Have read manual and cannot find out how to re set after oil change.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Savage
      Hi, 
      Does anyone have a free download link for this service manual? Thanks
    • By Travis
      View File Kawasaki Mule 550,520,500 Engine repair manual
      This file contains all specifications,troubleshooting and repair procedures for the FE290D  (9.5H.P,286cc) engine used in the  Mule 500,520 and 550 models.
      Topics covered include,  general information, service data, disassembly, reassembly,inspection of parts and maintenance.
      Notes:
      Make sure you're reading the correct information as this manual covers multiple FE series engine, some of which were not used in Mules, the manual does a very good job of clarifying which specifications and procedures are for which Model engine.
       
      Submitter Travis Submitted 01/13/2021 Category Kawasaki  
    • By MitchSpence
      I have a Massimo Buck 400. I want to change the engine oil.
      I know this is a "duh" question, but to do that I need to take the heavy plastic cover off that is mounted under the frame. Then find the drain plug which I assume is in the front of the vehicle. Did I get this right or can you guide me further?? 🤠
       
      Many thanks.
       
      Mitch
       
    • By ANIL SEDALI
      Hi friends. I'm Anıl. I live in Turkey. I have a Hisun 700 UTV 2015 Models. My problem is : 
      inability to change gear after the engine has started. Before the engine starts, it can shift into all gears; but after running, I cannot change gear. At about 3000 km. Fuel injection model. Can anyone help on this topic? Thank you!
    • By Alex
      View File 2010-2013 Kawasaki Teryx 750 Service Manual
      2010-2013 Kawasaki Teryx 750 Service Manual
      Includes:
      TERYX 750 FI 4x4
      TERYX 750 FI 4x4 LE
      TERYX 750 FI 4x4 SPORT
      Submitter Alex Submitted 01/10/2021 Category Kawasaki  
  • Similar Tagged Content

    • By Logan
      Ok so I have a Polaris ranger xp 08 I think . I started it up no problem( never had any ) drove it out of the garage about 15 feet and let it idle for about 5 mins . Then it started to sputter , gave it some gas and it stalled out. Tried to start it a couple times but wouldn’t go. I figured gas was low, put some in but same thing . So I got the ether and took the air filter off sprayed it in and it fired right up but would stall out instantly.  So I tried it again and gave it some gas but same thing . Next I just sprayed and jus got enough to gas it back into the garage . But then I saw flames coming out of the air intake . Was able to put it out quick ( 10 seconds) just by blowing on it . Before anyone says to much starting fluid I know a little goes a long way . I didn’t hold it down and jus spray , only a quick burst twice before stalling out . But where do I go from here ? Engine not getting enough gas ? But then why was I able to start/drive/ and idle at first ? Now I can’t even get it started . Let me know what you think.
    • By jwienrich
      HI new to the forum so this is my first post and problem. So I have a 2005 Ranger 500 6x6 with a carb and do not have any power to the fuel pump. Research has suggested that it could be the pdm but after looking extensively through my machine I cannot find a pdm. I can only find 3 flat black thin boxes under the hood on the passenger side. Are there some ranger 500's without pdm's? I bought this machine new and it has never been messed with. This machine has been in storage for several years and has only 12 hours on it.
      Thanks, Jeff
      My Bad just looked at my title and its a 2004 not a 2005 so no PDM or ECM. Wiring is quite different so I need to take another look.
    • By Hoytlifer
      I have a  2019  Ranger 900 XP EPS that I would like to change the factory headlights to LEDs.  Has anyone done this, if so what style of bulb was used.?
    • By Lester Richards
      Took it out the other day, it died and engine temp light came on and I heard the gurgling in the radiator. I let it cool for few, got it home in limp mode.  fan kicks on but im not sure 40 seconds is long enough and/or if it kicking on all the times when it needs to be. fan relay works id assume or fan would never operate. Took temp sensor wire off and fan does NOT auto kick on like I was told. No debris in front of radiator, its full , correct level on overflow tank. unit has 1,600 miles, iv had if for 6 months and all the sudden I get this issue.
    • By Brett
      Fuel injected 700 starts great and idles great but touch the gas and it dies


×
×
  • Create New...