Quantcast
Jump to content

rtate1050

Hisun fuel gauge

Recommended Posts

I've had my Massimo 500 for about a month. So far I'm really happy with it and until today haven't had any issues . When It was delivered, the fuel gauge had one bar so I put a couple of gallons in to get me going. Still showed one bar on gauge but I figured not enough to register. Today I thought that I'd add a 5 gal can to top off. Well, I learned that the gauge wasn't working when, you guesssed it, the tank overflowed after a couple of gallons in. Still only one bar on gauge.

I could probably figure this out by starting with the basics (checking wires , the sending unit , etc. ) but before I got a-rippin and a-tearin , I thought I might save some time and I'd check and see if anyone had already had  this problem and what the fix was.  This is a 2007 with the electronic dash. Everything else seems to work . Any help would be appreciated .

Rich

Share this post


Link to post
Share on other sites


Just an update . As usual, I was overthinking the problem based on what I read on the internet . Finally got around to pulling the pass. seat and found a loose wire where it goes into the plug on the pump. Pushed the wire securely into the plug and that fixed the problem. A perfect example of the  K.I.S.S principle.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...