Quantcast
Jump to content

LM300 engine upgrade options??


Recommended Posts

On 5/26/2022 at 3:15 PM, Buggy said:

The Harbor Freight Predator 420cc should work but verify your shaft size and rotation is the same. The Honda 390cc is a great engine but will cost a lot more.

might want to check the new Harbor freight 459cc engine.

Link to comment
Share on other sites

Keep in mind that the factory matches the drive clutch and belt to the engine horsepower. Too much horsepower will smoke the belt and maybe the clutch.. your factory setup should be ok with a modest upgrade. I think your drive setup can handle up to a 400cca and would not go more than 420cc unless you plant to  upgrade clutches and belt .

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By TomW
      I had a problem 6-8 mo ago when the unit would not start . But you could see power on the dash. The starter solenoid was replaced and it has been fine until yesterday. When I started it up I noticed a high pitched noise coming from under the front. Like a alarmbuzz ..It seemed to drive fine so I went ahead and used it off and on for a hour or so . The noise would not go away . I parked it in the shed and lifted the hood . It seemed to be coming from the battery compartment ( where the new starter solenoid is) I jiggled the connections and the noise changed timbre and then the machine went dead. No power at all . No lights . When you cross the two poles on the starter solenoid ( previously last year it would start and run ) nothing. Checked the battery and it is fully charged . I checked the fuses inside the battery box and they all looked good  but I must be missing something. Anyone have a clue what I need to do next to R&R. The closest repair place is 2 hours away in Mississippi . Any help would be appreciated.
    • By NDV45
      I have  2008 Cub Cadet Volunteer Tracker.  Was running fine, parked and next morning electric fuel pump inop.  Checked voltage had 4.2 volts.  Swapped relays in fuse box, checked all fuses (good) and still low voltage.   Does the ECU control the voltage to the fuel pump or which relay controls the voltage to the pump?
      Have checked all wiring and not found any place it could be shorted (not saying I may have missed something). I am at a loss.  Need Help Please.
    • By htrotte
      Is it possible to add power steering?  If so where do I find parts?
    • By REDfletching
      Spent today at a Honda dealership looking at their 520 side by side, then on the way home past our Lowes noticed they had several new UTVs on site, so we U-turned and ducked in there. We were impressed that all that came for $9,999 metal whole length skid plate, nice sized bed, roof, windshield, side mirrors, winch, upgrade looking tires… all of which would have added thousands of dollars to an already expensive Honda 520. Now Honda does have a great reputation from my trusted UTV experienced buddy, so it has that going for it.
    • By didgeridoo
      Hello, All!  I've decided to replace the traction batteries in my 2018 Sector E1 with a 48V Lithium set. They may be expensive, but I figure the Discovery Dry Cell are, too. I am not looking for the max driving range, as I have never received near the brochured range to begin with, but a good mix of charge/ get work done/ charge is what I am expecting.
      I have settled on the 48V EAGL kit from bigbattery dot com. Each battery pack provides 30Ah. The kit ships with a charger, as well. The packs would be physically connected in parallel (using a busbar) to one another, maintaining the 48V voltage, but together would be able to provide the amp draw the buggy pulls when going up hill or towing a rake (rated 320 max continuous Amps). This is in comparison to the serial connection the eight 6V lead batteries. Each of the EAGL batteries looks to have its own BMS; am I correct in thinking I will have to use their included charger rather than (simply) changing the onboard charger to lithium mode? The chemistry of the pack is LiFe PO4, for what it's worth.  I haven't torn anything apart yet (to diagram), so  I am not sure how the dash will interpret the AMP draw, but the kit I am looking at includes a dash mounted charge indicator.
      If anyone has completed a similar conversion, do you have any tips? Specifically, how did you remove the original batteries, and how did you secure the new ones? I am guessing that almost any change from the stock batteries would involve at least some modifications. Any tips would be appreciated, especially things I may have failed to consider. Thanks!
×
×
  • Create New...