Quantcast
Jump to content

MassBuck400

Members
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

1 Neutral

About MassBuck400

  • Rank
    Newbie
  • Location Athens, TX, USA

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I'm having another issue with my 2019 Buck 400. When I push in on the brake and turn the ignition to start nothing happens. If I pump the brake several times it will start right up. Does anybody know where the relat is that prevents it from starting until you apply the brake? I think it must be loose or something like that. Thanks for your help.
  2. Thanks I may try that. I'm retired so I have plenty of time.
  3. I don't believe so. It is not large enough to allow air to escape around it. Thanks for your reply.
  4. OK I called Massimo Tech service. It is as I thought but I don't like it. There is a hex nut at the bottom of the dipstick. You have to remove the entire dipstick to fill wit oil. Not a smart setup. It takes about 1.4 QT. of 10W30.
  5. Still looking for help changing the oil on my Buck 400. It looks like maybe I have to remove the shifting cable and the remove the dip stick? surely it is easier than that. This is a 2019 model. I have around 150 miles on it. Thanks
  6. Mine looks nothing like the illustration you sent. Mine is a 391cc engine in a Massimo Buck 400. So I believe the dip stick to check engine oil is the yellow one. Below it maybe 5 inches is a small plastic dip stick. It comes out and is maybe 3 to 3.5 inches long. If the engine oil is shared by the transmission? Maybe this is where to fill the oil. It seems to be to low for the engine oil? I have attached a photo I took today. Thanks for your help.
  7. I purchased this Buck 400 last year and having a few issues. Maybe some members have had these and fixed them. Here are my current issues with the B400. 1. Starting has become a challenge. Not the actual starting of the engine but to keep it running. When I turn the key, it starts up but as soon as I let go of the key and it turns back, the 400 dies. I have learned if I hold the key for a few seconds it will remain running. Not a clue as to what would cause this or how to fix it? 2. This thing is very hard to get in gear now. It grinds a lot before it goes in gear. Maybe the clu
  8. MassBuck400

    MassBuck400


×
×
  • Create New...