Quantcast
Jump to content

TSCO Vegas to Reno


Alex

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By dave pasch
      Got it running. The 4wd gets 12v power but does not engage. The posi traction (rear end) does not engage also.  Any one have experience / ideas on fixing these items?
       
      Thanks Dave
    • By joeam
      I have a 2018 TW450E that runs in my yard and slow good just will not go down the road seems to be running out of fuel where should i start? I have replaced both fuel and air filter drained gas and tried a small auxiliary tank same issue i have ordered a new vacuum fuel pump to try next anyone in Texas that works on these?
    • By Hugh
      My 2018 Hisun sector crew engine cut off after about 15 minutes run. There is no indicator of what is wrong, no error code just die and won't restart until it cool down. I notice that the fan is not running but the temp indicator is on low temp, no overheat indicator. I checked the radiator fluid, it is cool to touch.
      Cooling fans are working, I can hear it running once awhile if I can get the engine warm up enough.  Thank you for all the help.
       
      Hugh
    • By johnpeter
      2016 Polaris RZR 100S, Race Ready On Ebay
      https://www.ebay.com/itm/386728557369?

    • By mcraigchr
      I realize that many of you do not have diesel machines.  For those that do, this is for you:
      Just wanted to post my experience this past week.  Here in Texas, we had pretty good dip in temps.  For 4 days it did not get above 25.  At night, it was single digits or close to it.  I always put Sta-Bil fuel stabilizer in the storage tank (30 gallon).  And up until this tank I was using Power Service (white bottle) for anti-gel.  Never had an issue.
      This tank, however, I switched to Stabil All season (anti gel).  It is supposed to good down to -40.  Zap.  That is a big fat lie.  I put in twice the amount called for in the instructions.  Result was less than optimal.  I drove the SxS 100 feet (to go get the mail) and it died.  I looked at the fuel bowl and it was a cloudy, wax substance.  So, the Stabil did not work.  That said, I'm not sure that I ever tested the Power Service in the same manner.  So I am not saying that one is better than the other.
      What are your experiences?  Are these products inferior?  What do you folks in the northern states / Canada use?  Am I missing something?
      CC
×
×
  • Create New...