Quantcast
Jump to content

rocmoc

Gas Gauge!

Recommended Posts

My sending unit is junk. I ran out of fuel with it showing full. A tank full of fuel ago, I ran out with it showing 1/4 tank. I just can't count on it for anything. At any rate, I have learned to carry a one gal. fuel can with me.

rocmoc n AZ/Mexico

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ethan McKinney
      This is a carb model not EFI it was in pieces when I got it. I got it running by replacing the fuel pump had to bypass this little reservoir thing I can’t find how it goes back in please help. Machine runs good but I have fuel coming out of the drain on the carb. This is a pic of the reservoir thing thanks

    • By Chris B
      Hi,
      Don't know much about anything utv but I figured out my fuel pump wiring harness needed to be replaced. Installation looks pretty straightforward, plug into fuel pump and plug in the two pigtails. Question is: one of the Pigtails on the old harness I am replacing had a splice in the black wire and attached to a bolt on the engine. Is this necessary?  Is the black wire, I'm assuming it's the ground, grounded at the other end of the pigtail?
    • By James Moore
      First post here hope it is in right place as I get familiar with sight. Have a 2003 550 mule,kaf-300-c7. Put on a new carburetor  as old one was in bad shape, jet was frozen in body, although it cranked and idled fine. The problem is: it will crank and idle fine BUT with a slight movement of throttle it wants to die and when more throttle is given it picks up and runs fine. The old carb. and new one does the same thing. The adjustment with the plastic stop does no good. At a loss here. Could it be the fuel pump, as I know nothing about these kind of pumps. any help will be appreciated.
       Thanks, Jim.
       
    • By Red Good
      had no fuel pressure at the rail , checked all fuses ok , seems to have signal to the pump , checked the pump and replaced it . Still no go , where is the fuel pump relay on this particular machine? Thanks guys . .


×
×
  • Create New...