Quantcast
Jump to content

Lenny

engine and trans parts

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Randy Stevens
      Hey all, I bought a Hisun 550 back in June of 2019. After 6 weeks of ownership, this machine took to sputtering when started and under power. I checked everything I could think of before I took it back to place of purchase....(rural king), since it had a one year warranty.   They kept it almost two months stating they were waiting to get info from Hisun to rectify the issue (supposedly faulty drivers seat belt). I was told by the tech that they replace seat belt harness and cured the problem. It did! Ran just fine again for almost a year and now the very same issue has returned. After doing a little investigating on my own, I noticed that rural king did not replace the seat belt harness at all.  The wires to seat belt connector was cut and spliced and taped back together. Now I’m not real sure what the real problem is as that tech is no longer with company and can’t seem to locate the past work order for my machine.  Hisun customer service is non existent . I’m on my own and begging for help. Im mechanically inclined but if this is an electricical issue, I’m screwed! No warranty left. Any help would be gratefully appreciated.
    • By j.fulciniti
      Hello Folks - newbie here with my first post so go easy on me.  I picked up a Buck 400 in May 2020 direct from Massimo when they were doing a closeout sale on the 400 models.  I read the reviews and was skeptical. 
      We live in a golf cart community  we do not plan any off roading - just some very mild work tasks like hauling firewood / brush etc.  Honestly, all we do is cruise around our neighborhood roads.  I pulled the trigger b/c the price was cheaper than a 2WD lifted golf cart and the Buck  had way more features.
      We have a few steep hills and after about 20 - 30 minutes of cruising, my check engine light comes on.  It only happens when we are going up or down one of the hills .  We head straight home and things seem fine the next day.  Light never comes on unless we tackle multiple hills during one ride.
      Should I be worried?  
      PS - Unit is 4 months old and has 258 miles on it - barely broken in.  I've yet to go full throttle on a flat or up a hill. 
    • By CharlieCampbell
      I recently purchased a used 2008 Ruesch XR.  The Pinyon is gone in the rear differential and the differential needs to be rebuilt or replaced. Does anyone know where you can find Ruesch parts?



    • By blacktrain
      2014 Massimo MSU 400 idles perfect, runs ok up to half speed.  From half speed if you step down on the gas pedal all the way engine dies.  Engine is fuel injected, the map sensor, and the throttle body idle control sensor, and the fuel injector have been replaced.  Also the fuel pump was removed and fuel pressure is ok, and fuel was checked for water.  Air box and air filter have been cleaned, also replaced spark plug.  From a dead stop if you step right down on the gas pedal all the way it dies, if you baby it, and go easy it will run ok until about half throttle, then after that it will  die as you start to push down more on the throttle for top speed.  Any ideas?  I appreciate anyone's help...


×
×
  • Create New...