Quantcast
Jump to content

1977 Ford Bronco


Recommended Posts

Selling my bronco because I just dont use it and am out of space in my garage. I'm not dying to part with it but I figured there is always something new. I've had this car for almost three years now and have never had any serious mechanical problems with it. The restoration was completed by a private individual who spent a significant amount of time building the car for himself. Car runs great. Has a great "muscle car" type sound to it. This car is right at home off roading, cruising out to the lake (what I used it for), or just running around town on a Saturday. The Bronco has approximately 8500 miles since restoration. Please ask any questions: [email protected], thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By buckrub
      Hey guys! Newbie here. I'm an old man who's better with plowing a mule (4-legged kind) than these newfangled beasts. I, and a friend of mine, just bought new Coleman sxs and are having to finish the assembly. I've been reading on this site and I'm falling on the mercy of you experts. The only way I'm an expert is that an "ex" is a has been, and a spurt is a drip under pressure. LOL First off, the 2 buggies have no ignition switches. They seem to mount on the dash, not the opening in the steering wheel shaft cover, so we ordered new ones that are supposed to fit. They are 8 inches long, and have a 4-wired white plugin which is slightly rectangled when looking at the end of the plug. The trouble is there's nothing to plug into. There is a three-wire grey plug close enough to reach the four-wire plug, but of course, they are not compatible. 
      Secondly, the blinker, light, ect. unit on steering wheel just spins around when touched. I see no way in heaven or earth to secure it. I've looked at a diagram on the Powersports site, but can't detect how it mounted. Fellows I'd be so grateful for any help with this. Me and my mule will even plow your garden for free, for your help. LOL 
       
    • By AlphaSerenity
      Hello,
      Before I invest $10k+ into a brand new UTV for the farm, I want to get my feet wet with a fixer upper and learn the mechanical side of things. I acquired a 2022 Hisun Axis 500 (Lowes-specific model) from an auction for $500. It has only 200 hours and 120 miles on the engine. It looks like the previous owner used it for ranch work and didn't drive it on trails, deep water/mud, or anything too crazy.
      While it runs and moves, it has some problems. It struggles to accelerate up any incline in high and low range and sometimes stalls when I let off of the throttle or change gears. When I apply throttle in neutral, it sounds like it is struggling for fuel/air and pops. When I decelerate, there is a grinding sound coming from the clutch, which I've read to be related to the one way bearing and is semi-common. The last thing I've observed is sometimes the speedometer display sometimes will show a much higher value for a few seconds after barely touching the throttle. Based on the documentation, if a problem is detected from the sensors, the instrument panel display should have an error code rendered on the screen in place of the time, but this isn't happening. Here is a video showing some of these issues (engine is exposed with console removed):
      https://www.youtube.com/watch?v=FFAkO5TaGps
       
      Here is another video of the clutches in action:
       
      I've done some research, but information on this specific unit and sister units is limited. There does seem to be transmission and clutch issues reported. I still need to check into the head gaskets. I don't have the equipment to test compression right now, but I do plan on ordering what is needed soon. I do have an order in place for some cables to read the diagnostics from the computer. There is a shop two hours away from me that works on Hisun products, but I am hoping the problem can be identified and is something within my ability to handle. Below is what I've already investigated.  I am leaning towards the primary clutch needing replacement right now.
      After getting it home and unloaded, I did the following maintenance/checks to it prior to operating it further:
      Changed the engine/clutch oil (and filter) and gear oils using manufacture recommended viscosity Changed the air filter and checked for cracks in the air intake flow. Verified good suction. Cleaned the throttle body Changed the spark plug and verified the gap was within spec (0.6-0.7mm) Changed the coil and coil wire Changed the fuel lines, fuel injector, and verified the fuel pump was outputting the correct initial prime pressure for ignition and continuous pressure after ignition. Also completely emptied the fuel tank and made sure octane 91+ fuel is being used per manufacturer specs. Ran seafoam through system too. Cleaned the spark arrester and verified no cracks or gaps in the exhaust flow Changed out the O2 sensor Checked all wired connections to ensure they were secured and no breaks were visible Checked the belt for tightness and for any signs of wear and tear Verified 4WD and the differential lock function as expected - still hesitates and struggles uphill Verified the fan gears in the shifter are not corroded and working as expected ECU was reset after replacing sensors and fuel-related parts  
       
      Thanks!
    • By Robert B
      Going down a 20 deg hill engine is holding UTV back. Then something releases like going into Neutral and makes a loud clacking noise. Have to use brake to slow UTV down. Then once level it shifts back into gear. Have done shift extension does not pop out of gear.
    • By Steve Toney
      Hello, my name is Steve and just signing up.  Bought my first UTV yesterday.  It is a Massimo T-Boss 550.  
    • By SafeSledBryan
      Hey guys! My name is Bryan and i am the owner and creator of Safe Sled. Not some crazy corporate backed recovery product, but just some guy with an idea. 
       
      4 years ago, I suffered 11 strokes, and am now 50% paralyzed on the left side of my body. I am unable to work a normal job anymore. I was working on the sled 2 years before this all unraveled. My wife told me to keep working on it since i was pissing her off staying home and doing nothing.
      I still plan on improving and implementing different ideas as the product’s revenue continues to grow.
      if the sled is appealing to you, please check out my website, safesledoffroad.com
      Safe Sled Website
×
×
  • Create New...