Quantcast
Jump to content

Polaris 500 noise and no engine braking.


adjusterr
 Share

Recommended Posts

Purchased 2013 Polaris 500 Ranger last week. No engine brake at idle just like in a previous post. Also, just before the freewheeling starts, there is a high pitched whining noise in the differential/tranny area like raw metal rubbing. Called dealer, was advised this is normal. If I had been aware of this problem prior to purchase, there would have been no purchase, this thing seems unsafe. If you release the accelerator on a steep hill the machine will slow down then as the engine reaches idle speed rpm's, the unit makes a screaching sound and goes into freewheeling requiring immediate and hard braking. Anyone out there having the same problem and is there a solution? Thanks

Link to comment
Share on other sites

I would bring it to dealer and argue and make them ride with me and demand it be repaired under warranty with no charge to you, or refunded under the "lemon law"

Otherwise u could inspect the cvt continuously variable transmission to see what's going on and repair if needed.

I feel for you, If its bought new it gotta work out the box like intended to.

Sent from my DROID RAZR using Tapatalk 2

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Topics

    • By Steve Vanvelzen
      I Recently purchased a Massimo T-Boss 550F last fall with their 60" snow thrower because I couldn't find a decent UTV here in Southern Ontario; nothing in stock anywhere. I am having really bad buyer's remorse after spending time on it and reading all the bad online reviews. The company boasts the fact that it is built in Texas, USA, so I was hoping to do the right thing by buying, "Made In North America" but it is still Chinese Junk, assembled in the USA. and I am starting to realize that I am going to have a lot of difficulty getting parts for this thing; I can't even get an oil filter, finally bought a "Hisun" filter and hope it fits. i busted the shear pins in the snow thrower and can't find replacements for that either. The thing is so hard to change gears most of the time; I am terrified I am going to wreck something. The place I purchased it from is absolutely useless. Can I adjust something myself? Anyone out there have this problem and have some advice (besides selling it and buying a good brand)?
    • By Tx1Tek
      I just recently purchased a
      Hi Everyone. I'm new here.  I recently purchased a 2016 RZR 570 Trail. I was looking for the Polaris drive belt number in the manual, but they don't list the belt number there. Does anyone here know the Polaris Drive Belt part number? Why wouldn't they list a part number for that critical part?

    • By johnpeter
      2019 Polaris RZR 4 1000 Turbo S On Ebay
      https://www.ebay.com/itm/175108075553?

    • By rangerstein
      The middle two tires on 6x6 are spinning. the drive shaft from middle to rear is spinning and the shaft from middle to front is spinning. I have the entire thing jacked up. When I first start it both middle tires will spin and the front two will spin for about 10 seconds. the rear tires do nothing. I can spin the rears wheels both forward or backwards at same time or one forward and one backward and vise versa. Is this normal. Do I have a rear differential broke or is something not engaging the shaft to the gears in the back. Would somebody please tell me how all the drive system works together so I can find something to fix of replace.
    • eManualOnline
    • By Alex
      Its maker has affectionately dubbed it Teslaris, for obvious reasons.
      The Polaris RZR RS1 UTV has a one-liter, two-cylinder engine that from the factory has around 100 horsepower, making the 1,383-pound (627-kilogram) UTV very quick. But there’s always room for more power in one of these vehicles, and instead of fettling with its engine, one dune vehicle aficionado decided to swap in the rear drive motor out of a Tesla Model 3 / Model Y.
      We don’t know how many of the battery modules the put in the vehicle, but it doesn’t appear to be much heavier than stock and it goes up sand dunes with remarkable ease. Depending on which version of Model 3 was the motor donor, the drive unit could have either 261 or 325 horsepower, as long as the battery pack can supply enough wattage and voltage.
      Judging by how easily it flies up the steep sand dune, almost lifting the front wheels off the ground under harder acceleration, it’s safe to say it looks like a real hoot. The steep grade you see it tackling in the video uploaded by the electric UTV’s creator, Ron Cobbley, is located in the St. Anthony, Idaho sand dunes.
      We found more videos on vehicle’s official Instagram account and aside from how interesting it is to see an electric powertrain in an application like this (and how it changes the vehicle), we also noticed that you really hear the tires on the sand more. Usually, this sound is drowned out by the engine.

      The sound’s tone and pitch probably change with speed, giving the driver audible information to help him or her gauge their speed. You don’t really get this in a road-going EV driven on tarmac, which is why it’s trickier to drive an EV quickly - specifically because you have no way of knowing how fast you’re going just by ear.
      Source: https://insideevs.com/news/559789/polaris-utv-tesla-motor-dunes/
  • Gallery Images


×
×
  • Create New...