Quantcast
Jump to content

Sign in to follow this  
3wheelermaniac3

Noob from Louisiana

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Dan B
      Does anyone know if Joyner USA in Phoenix AZ is still in business.  Can't get onto their website.  The FB postings are over 1 year old.  Doesn't seem like the owner is interested in keeping customers interested or updated in what's going on.  Hasn't been at the Riverview address in a couple of years.  Last I knew, he was on S 18 St.  There's a website that says Joyner USA is at the 3700 block of E Roeser.  Don't know at the moment if it is the same business.  I bought a couple of wheels from him last year and I want to buy two more.
    • By MMaster
      Have a new r4 approx 800 miles just noticed the tach wont sweep with ignition on but the speedo does, also will start with out the clutch engaged.  my 2012 r4 tach and speedo both sweep and it wont start unless the clutch is engaged , any ideas why?. Any help would be greatly appreciated.  Thanks Matt
    • By Terrypenton
      Bought this machine a couple years ago and the gages didn’t work.  I have troubleshot this thing numerous times to no avail. Thought it may be a common ground so I individually grounded  the gages, didn’t work.  I have tested the sending units.  All have some resistance that changes as the engine revs or gets warmer.  Please help me.  Thanks in advance
    • By xbodyman
      Does any one have a wire color code on wires one the rear relays on a trooper 2 2008 model i had a lower relay on  the rear fuse block  melt down so i pulled the wire couldnt remember so i looked and thought the black with read was ground any way its a mess please help if you can thanks  Bodyman  ps also were do people get parts now days i could use a fuel sender thanks agin


×
×
  • Create New...